If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Property ALT of HTML Tag IMAGE doesn't show the tooltip when viewing a page.

VERIFIED DUPLICATE of bug 25537

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 25537
13 years ago
13 years ago

People

(Reporter: Wander, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

56.22 KB, application/octet-stream
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

We've programmed a HTML Tag IMAGE, and defined a tooltip as below:
   
  <img src='image.gif' alt='this is an image' height='10' width='100'>

but when putting the mouse over this image, Firefox does not show the Tooltip
'this is an image'.

please compare with Internet Explorer, because it works fine. The property ALT
should work in any browser.

Reproducible: Always

Steps to Reproduce:
1. Create or choose an existing image, put it in a Windows' folder.
2. Create a HTML File in that Windows' folder and append the line <img
src='image.gif' alt='this is an image' height='10' width='100'>
3. Open Firefox and choose File, Open File..., then choose the HTML file created.
4. Move the mouse over the image you defined in HTML file code.
5. The tooltip 'this is an image' does not appear.
6. Open the same HTML file with Internet Explorer.
7. The tooltip 'this is an image' appears.
Actual Results:  
The webpages that implements the "alt" property does not show the tooltip in
Firefox. Meanwhile Internet Explorer can show the text value defined in HTML
file code.

Expected Results:  
Firefox Must show tooltip for HTML "ALT" property like others browser do. 
It must show the text when getting the mouse over a link, image, or other TAG
element, as if were a "TITLE" property.

No themes used. Just install Firefox and check if programmed tooltips really
appears when surfing the web.
Environment

Windows 2000 5.00.2195
Service Pack 4
Intel Pentium(R) 4 2.40 GHz
RAM 523.808 KB
(Reporter)

Comment 1

13 years ago
Created attachment 175473 [details]
ALT property bug 

Just decompress the two files on desktop and pass the mouse over the picture

Comment 2

13 years ago
Firefox is working correctly in not showing the ALT text.

The ALT text is "alternate text that is rendered when the image cannot be
displayed" (HTML 4.01 Specification
http://www.w3.org/TR/html4/struct/objects.html#h-13.2).

The fact that IE does it does not make it correct behaviour.

To get a tooltip for an image, specify the TITLE attribute. (You can always
specify both if you need this to work on older browsers).

E.g. <img src="image.jpg" alt="This is an image" title="This is an image">

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.