Netscape acting as a server?

VERIFIED DUPLICATE of bug 28403

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 28403
19 years ago
18 years ago

People

(Reporter: Arn Burkhoff, Assigned: Gagan)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I have a personal firewall, Zonealarm, installed and inorder to use Mozilla I 
had to authorize Mozilla as a server. This makes me very uncomfortable. 
Mozilla also crashes at startup with ZoneAlarm running when denied server 
capabilities.

Comment 1

19 years ago
This is a browser bug, not architecture. Reassigning.
Assignee: endico → gagan
Product: Architecture → Browser
QA Contact: nobody → tever
Version: 5.0 → other

Comment 2

19 years ago
*** Bug 28362 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
*** Bug 28363 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
Need more information on this. What were you trying to do, just use http, or 
ftp? What happened -- what sort of failure: assertion, dialog, nothing?
Target Milestone: M15

Comment 5

19 years ago
Subject: 
             Bug 28361
        Date: 
             Tue, 22 Feb 2000 08:17:35 -0500
       From: 
             Arn Burkhoff <arnb@myself.com>
 Organization: 
             Unorganized Masses Inc.
         To: 
             warren@netscape.com




In the commments for this bug you asked what I was trying to do.

I was attempting to start Mozilla. I had it authorized as a program that
could access the internet but it required server status in order to run
and not crash. A simple method of testing this is to install
ZoneAlarm(it's free for personal use) at www.zonealarm.com and see what
occurs.
-- 
Arn
http://www.injersey.infi.net/~arneb/

Comment 6

19 years ago
Does it crash in NECKO.DLL or in UCONV.DLL? There are files for these two start 
up bugs using ZoneAlarm filed under bug 28403 respectively bug 30831.
This information could be useful in order to solve these.
(Reporter)

Comment 7

19 years ago
These are the details from the failure. Simultaneaoulsy Zonealarm
produces a warning saying Mozilla.exe was prevented from acting as a
server.

MOZILLA caused an invalid page fault in
module UCONV.DLL at 0177:607f4905.
Registers:
EAX=00000000 CS=0177 EIP=607f4905 EFLGS=00010206
EBX=00000000 SS=017f ESP=0068f9f0 EBP=0068fa60
ECX=0068f9fc DS=017f ESI=0086eb34 FS=3b67
EDX=00000073 ES=017f EDI=0068fba8 GS=4c76
Bytes at CS:EIP:
8b 38 8d 45 f8 50 53 ff 15 cc 70 7f 60 50 ff 35 
Stack dump:
0068fba8 0086eb40 007b4cd0 60c6be08 00000025 0000003f 00000000 00000000
0068fa14 6f736572 65637275 65722f3a 68632f73 65737261 696c6174 702e7361 

Comment 8

19 years ago
Thanks a lot for filing. I added your comment on the missing server permissions 
to bug 28403. This will help a lot.

*** This bug has been marked as a duplicate of 28403 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.