Closed Bug 283611 Opened 20 years ago Closed 20 years ago

Select drop down not rendered anymore when innerHTML is used

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: yuanyi21)

References

()

Details

(Keywords: regression, testcase)

The url is the testcase from bug 283036.
After clicking on the "doe" button, you should still see a select drop down, but
with different options. 
But in the 2005-02-24 build, the whole select drop down disappears: the height
of the select seems to become 0px. This bug wasn't there in the 2005-02-23 build.

In my own build without the fix for bug 268513, I can't see this bug. After I
applied the fix for that bug and built layout/ I can see this bug.
So the fix for bug 268513 seems to be the cause for this regression.
To bug 268513 patch author, though I'm not sure what that's being triggered here...

I suspect the problem is that there are multiple frames that all have the same
mContent here and one of them dies, which kills the anon content for the whole
thing.  Perhaps we should check whether there is a primary frame mapping for the
content node and if there is remove the anonymous content only if the primary
frame is the one being destroyed?
Assignee: nobody → kyle.yuan
Severity: normal → major
Flags: blocking1.8b2?
OS: Windows 2000 → All
Hardware: PC → All
Ok, the back-out of the fix for bug 268513 fixes this bug.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Flags: blocking1.8b2?
You need to log in before you can comment on or make changes to this bug.