cannot tell which radio button is selected

VERIFIED DUPLICATE of bug 25979

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 25979
18 years ago
18 years ago

People

(Reporter: Andrew Brobston, Assigned: dcone (gone))

Tracking

({pp})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Another one I cannot believe hasn't been reported -- I really need to learn to 
do better queries...

Reproducible: Always
Using Win98 M13 build and/or 2000-02-17-15 build:
1. Open the browser and load the URL.
2. Scroll down to the series of choices beginning with "Run this query."
3. Try selecting several different radio buttons.
Actual result: You cannot tell which button is selected.
Expected result: Um, you can? :)

This bug might be related to bug# 28366 somehow.

Comment 1

18 years ago
Can you attach a screen shot?  On my Linux build, I see a black dot in the
selected radio button.

Comment 2

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods
(Reporter)

Comment 3

18 years ago
Created attachment 5417 [details]
screenshot of Win98 2000-02-17 build
(Reporter)

Comment 4

18 years ago
Screenshot would be essentially the same in M13, just different build number.

I noticed that, after doing some work in another window and coming back to the 
Mozilla window in the screenshot, the radio buttons actually looked like radio 
buttons, black dot and all.

Does this have something to do with rendering the radio buttons themselves? If 
so, this is probably a duplicate of bug# 28366.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Weird. Mark pp since it doesn't happen on Linux.  Confirm so Rod takes a look at
it.

Updated

18 years ago
Keywords: pp

Comment 6

18 years ago
Kevin, could you take a look, this seems to be a rendering issue specific to 
Win98
Assignee: rods → kmcclusk
I'm guessing that this is another palette issue. I can't reproduce it but I have 
seen other palette problems which cause the form controls to change colors. It 
may be rendering the selection in the same color as the background of the radio 
button. 

Don, after you look at the palette issues, check this bug.
Assignee: kmcclusk → dcone
(Assignee)

Comment 8

18 years ago
Is this happening with 8 bit color (256 colors).  
Status: NEW → ASSIGNED
I'm seeing identical behavior under M14 for Linux.  The radio buttons are
redrawn correctly if I move the scrollbar even the tiniest bit.

This fixed itself after restarting Mozilla, I can no longer reproduce.  Sorry,
should have tried that before posting here.

(Assignee)

Updated

18 years ago
Target Milestone: M16
(Assignee)

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 25979 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.