Closed Bug 283820 Opened 15 years ago Closed 15 years ago

Download Actions shows and allows editing of multiple entries for same file extension.

Categories

(Firefox :: Preferences, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: bram, Assigned: bugs)

Details

(Keywords: regression)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225 Firefox/1.0+

The Tools -> Options -> Downloads -> Download Actions -> View & Edit Actions
dialog shows two entries in the list for the MP3 extension in my case. Both
entries can be assigned different actions which is confusing.

This might be accountable to some application registering itself wrong, but it
would be nice if Firefox filters the list and removes one of the entries.

Reproducible: Sometimes
->NEW
->Normal ? (not sure this shouldn't be Major)
->regression
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
->INVALID?

The same file extension can be used for many different mime-types?
Please attach your mimeTypes.rdf file from your profile. 
Attached file mimeTypes.rdf
Attachment #175716 - Attachment mime type: application/rdf+xml → text/plain
(maybe related) is there a reason why none of the realplayer
extensions/mime-types get picked up by the Download Actions window, even tho
realmedia embedded in websites works just fine.
Flags: blocking-aviary1.1?
If the mime type is significant shouldn't the list show the mime type then?
I get sometimes questions what to do with the file type that I have already
defined with "don't ask me again". Is it effect of this bug?
(In reply to comment #7)
> If the mime type is significant shouldn't the list show the mime type then?

This feature is available in current builds -- you have to select the column for 
MIME types in the Download Actions dialog (each time you open the dialog); or, 
if you click Change Action, the MIME type is shown at the top of the new dialog.

Interesting to me: the mimeTypes.rdf file doesn't specify an extension for any 
of the MP3 types, altho it defines handlers for audio/x-mp3 (Open with default) 
and audio/mpeg (Save to disk).  It must be retrieving the extensions associated 
with those types from the Windows registry.
This is by design, extensions to mimetypes is a many-to-many relationship, so
this can be a valid situation.
Status: NEW → RESOLVED
Closed: 15 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Resolution: --- → INVALID
This still doesn't make sense to the average user. If mime-types are the primary
key to the action entry and you expect users to understand that, why not show
the mime-type column by default?

In my opinion both (filename-)extensions (hidden by default to windows users)
and mime-types don't make sense to the average user and I feel that actions
should be grouped and unified by file type. 

To clarify: Why would the average windows user want to play a video/x-ms-wm with
the plugin and an video/x-ms-wmv with an external player? (both having different
mime-types, different extensions but the same file type description)
Maybe invalid but something looks wrong though.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.