Closed Bug 283902 Opened 15 years ago Closed 12 years ago

Layout broke with Tahoma as Sans Serif on slashdot.org with Firefox 1.01

Categories

(Core Graveyard :: GFX: Gtk, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jonsmirl, Assigned: blizzard)

References

()

Details

(Whiteboard: [CLOSEME 07/01] [pango])

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Links at slashdot.org are gettting their text length computed wrong when using
MS Tahoma as the Sans Serif font. Other fonts do not appear to be impacted. The
text for the link is longer than the space being left to paint it in. This
causes some letters to be over written at either end of the link. Layout at this
site was ok before the 1.01 release.

Other sites don't have problems with tahoma. Probably an issue with the CSS
style sheet slashdot is using?

Reproducible: Always

Steps to Reproduce:
1. set tahoma as san serif font
2. goto slashdot.org
3. look at layout problems

Actual Results:  
Link text over writes normal text for a few characters at beginning and end of
links.

Expected Results:  
Text should not have been over written
Do you have a shorter testcase?
I'm just a slashdot user. I received Firefox 1.1 from Redhat Update2date and
then browsed by slashdot.org and it was broken. 

Looking at the errors more closely it is italic links in flowing italic text
that is broken. Most of the slashdot stories are italic so almost all of the
stories look broken.

Current top story has the italic phrase <i>... called <a>Rockbox</a></i>. The d
and the R are painted on top of each other.

My guess would be that the text length computation is using the non-italic
length instead of the italic one. Italic on Tahoma may be slanted more than most
fonts so the error is more visible.
caillon, is this pango fallout?

Reporter, can you set the environment variable MOZ_DISABLE_PANGO to 1 and run
Firefox?   Do you still get the same rendering issue?
MOZ_DISABLE_PANGO to 1 fixes the layout problem

[root@jonsmirl init.d]# rpm --query pango
pango-1.6.0-7
Over to gfx.  Note that this is only an issue with RedHat builds -- the
mozilla.org builds don't use Pango yet.

Caillon, what were you saying about there being no Pango bustage yet?  ;)
Assignee: nobody → blizzard
Component: Layout → GFX: Gtk
QA Contact: layout → ian
Can you attach a screenshot and a dump of your preferences?  I can't reproduce here.
Attached file Preferences
Fonts are from latest Win2K service pack

[jonsmirl@jonsmirl .fonts]$ ls -l /dos/winnt/ServicePackFiles/i386/tah* -l
-rwxr-xr-x  1 root root 260472 Jun 19  2003
/dos/winnt/ServicePackFiles/i386/tahomabd.ttf
-rwxr-xr-x  1 root root 265528 Jun 19  2003
/dos/winnt/ServicePackFiles/i386/tahoma.ttf
[jonsmirl@jonsmirl .fonts]$
Attached image screenshot of osnews
Screenshot makes it obvious that Italics text length is not being measured
correctly.
Hello,

i have similar problems under gentoo linux with firefox 1.0.1.
The layout is broken on slashdot, see screenshots
here: http://bugs.gentoo.org/show_bug.cgi?id=83799

Regards

Flo
Could this be a kerning issue with Tahoma? When I select italic text and move
the selection around, letters in unselected text are jumping around to all
different kerning positions.
The patch to fix this should have been shipped in the update for firefox that
recently went out with the security update - the other distros should pick it
up, too.  Since this code hasn't even made it upstream to mozilla yet I'm
marking as fixed.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
The code for this has finally made it into the distributed browser. You have
fixed the problems with the layout length. But the line still shimmers as you
move the selection around. The shimmering is caused because the intercharacter
spacing of the words to the right of the selection changes depending on which
characters have been selected. 

The problem is generic with italic text, slashdot is just a good place to see
it. I tried several fonts, most work. MS Tahoma, MS Comic Sans, FuturaBlack MT,
Impact and Pigiarniq are still broken. Set one of these as you sans-serif font.

To see the problem go to slashdot and start selecting characters on a line in
italics. The rest of the line to the right of the selection will shimmer as the
glyphs jump around one pixel to the left or right depending on the length of the
select at the start of the line. Non-italic text is ok. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached image Slashdot, Times 16
I am running firefox 1.5rc3 on OSX (10.4.3).  I get the same problem with the default Times 16 font.  This problem occurs on other pages too, but it is most obvious with SlashDot.  I have attached a small screenshot.
I've noticed a similar layout glitch in one of my web pages. I have made a cut-down version of the page that shows the same problem at <http://www.alleged.org.uk/pdc/2005/gentium-test.html>. The screen capture shows the same page in Safari Version 2.0.2 (416.13) and in Mozilla Firefox 1.5 (Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5) on Mac OS X 10.4.3 

The font in this case is not Tahoma but Gentium <http://scripts.sil.org/gentium/>, a freely downloadable font I've installed on my PowerBook at home and on a PC at work.  Firefox on Windows XP does *not* show the same display glitch: only the Mac OS X version does.

Also, transitions between roman and italic text is sometimes the cause but not always: underlined link text also ends up mushed up against the previous word.
Blocks: 321251
Does this bug still occur in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Whiteboard: pango → [CLOSEME 07/01] [pango]
No response - works for me
Status: REOPENED → RESOLVED
Closed: 15 years ago12 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.