If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Repeatable crash on page load

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
P3
critical
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: mats, Assigned: edburns)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
DESCRIPTION:
Repeatable crash when loading http://www.sit.wisc.edu/~ssa/
The problem seems to be the Applet in the right subframe:
http://www.sit.wisc.edu/~ssa/consult/java.html

DOES NOT WORK CORRECTLY ON:
Mozilla nightly build 2000021708 on Windows NT 4.0 sp6.

WORKS CORRECTLY ON:
Communicator 4.7 on Windows NT 4.0 sp6.
MSIE 5.00 on Windows NT 4.0 sp6.

ADDITIONAL INFO:
Stack crawl:

gkhtml!nsTextFragment::CopyTo [omap] 
gkplugin!NSGetFactory 
jpins32!<nosymbols> 
jpins32!<nosymbols>  (FPO: [2,0,1])
gkplugin!nsGetServiceByProgID::operator= 
gkhtml!nsTextFragment::CopyTo [omap] 
gkhtml!nsTextFragment::CopyTo [omap] 
gkhtml!NS_NewPresShell 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewFrameManager 
gkhtml!NS_NewDocumentFragment 
gkhtml!NS_NewPresShell 
gkhtml!nsTextFragment::CopyTo [omap] 
gkhtml!NS_NewPresShell 
gkhtml!NS_NewDocumentFragment 
gkhtml!NS_NewPresShell 
gkhtml!NS_NewDocumentFragment 
gkhtml!NS_NewDocumentFragment 
gkhtml!NS_NewDocumentFragment 
gkhtml!NS_NewPresShell 
gkhtml!NS_NewDocumentFragment 
gkhtml!NS_NewPresShell 
gkhtml!NS_NewPresShell 
gkhtml!NS_NewPresShell  (FPO: [2,0,2])
gkhtml!NS_NewPresShell 
gkhtml!nsStyleChangeList::Clear 
gkhtml!NS_NewHTMLDocument 
gkhtml!NS_CreateHTMLElement [omap]  (FPO: [2,0,2])
gkhtml!NS_CreateHTMLElement [omap] 
gkhtml!NS_CreateHTMLElement [omap] 
gkparser!CNavDTD::CloseBody  (FPO: [1,0,2])
gkparser!CNavDTD::CloseContainer  (FPO: [3,0,3])
gkparser!CNavDTD::CloseContainersTo [omap] 
gkparser!CNavDTD::CloseContainersTo [omap] 
gkparser!CNavDTD::DidBuildModel 
gkparser!nsParser::DidBuildModel  (FPO: [1,0,1])
gkparser!nsParser::ResumeParse  (FPO: [EBP 0x00000000] [2,0,4])
gkparser!nsParser::OnStopRequest 
!is_wctype 
nspr3!PR_Realloc  (FPO: [2,0,0])
xpcom!nsCOMPtr_base::begin_assignment  (FPO: [3,0,0])
urildr!nsGetInterface::operator= 
nkhttp!nsProxyObjectCallInfo::operator= 
nkhttp!nsProxyObjectCallInfo::operator=  (FPO: [5,0,2])
necko!NSGetModule  (FPO: [1,0,0])
necko!NSGetModule  (FPO: [1,0,1])
xpcom!PL_HandleEvent  (FPO: [1,0,2])
xpcom!PL_ProcessPendingEvents  (FPO: [1,0,2])
xpcom!PL_IsQueueOnCurrentThread 
user32!TranslateMessageEx
(Reporter)

Updated

18 years ago
Keywords: crash

Comment 1

18 years ago
Doesn't crash on 2000022716 Win98, however;

http://www.sit.wisc.edu/~ssa/consult/java.html just loads a black screen and 
says Document Done. The Java applet doesn't appear to be loading properly.

Comment 2

18 years ago
Re-assigning to Ed Burns; possible duplicate of 23672?  (perhaps
paw@netscape.com or rajendra.pallath@eng.sun.com can help verify?)
Assignee: drapeau → edburns

Comment 3

18 years ago
Tried the same on WinNT V4.0 with SP5 
Used the Mozilla build on 02/25/2000
and latest  java plugin from Stanley Ho (dated 02/25/2000).

The applet does load correctly, abd the page does not crash the browser.

(Assignee)

Comment 4

18 years ago
This no longer crashes the browser, but it runs horrendously slow.  I'm not 
sure if the applet is written that way or if it's a JPI problem, but I'm going 
to mark this fixed since it doesn't crash.

Follow these steps to replicate my success.

02 March 00

Here are the steps I took to enable the viewing of applets in mozilla.

STEP 8 IS THE MOST IMPORTANT, and UNUSUAL step.

1. Check tinderbox to see that it's green for win32 clobber

2. Checkout SeaMonkey at around 11:30am on 02 March 2000

3. Built Mozilla with MOZ_DEBUG=1

4. Used the WINNT Add/Remove programs feature to remove any JRE and JDK
   instance I had installed on my machine.  Then I rebooted.

5. Used a find command to make sure there were no instances of any of
   the following files on my C: drive:

   jpins32.dll
   npjava*.dll
   jpishare.dll
   jaws.jar

   This step is also intended to catch the case where you have Netscape
   Navigator 4.x with the Java plugin installed, which I don't.  If you
   do, you must make sure that you don't have the plugin installed.

6. Downloaded the JRE Release Candidate (RC) 1 release by visiting:

   http://developer.java.sun.com/developer/earlyAccess/j2sdk13/
  
   And choosing the "One large bundle" option under the heading

     Internationalized version of Java 2 Runtime Environment 

7. Ran the installer exe.

8. Unzipped George's zip file on top of the install location, which for
   me was C:\Program Files\JavaSoft\JRE\1.3 .

9. Copied C:\Program Files\JavaSoft\JRE\1.3\bin\npjava*.* to my mozilla
   plugins directory, which is:

   D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\plugins

10. Ran 

   D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\mozilla.exe

After doing the profile manager dance, I was able to view applets
without java-related crashes.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
No longer crashes.  Verified in build 2000030609.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.