recursion with <iframe>s hangs or crashes Mozilla Suite & Firefox

RESOLVED DUPLICATE of bug 228829

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 228829
13 years ago
13 years ago

People

(Reporter: Rotten, Unassigned)

Tracking

({crash, hang, regression})

Trunk
x86
Windows XP
crash, hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

i was looking on google for something, and this site was one of the first, so i
clicked it, after a few seconds FF stalled, i assumed it lagged, but the RAM and
CPU usage kept going up, eventually crashing FF at 99%cpu, and 250mb RAM.

im not sure what code was used in that site, but it isnt good for ff. :p 

Reproducible: Always

Steps to Reproduce:
1. goto website
2. wait 5 seconds
3. ;) 

Actual Results:  
ff cpu&ram usage build slowly, eventually killing firefox.

Expected Results:  
loaded the page?

im using win32sp2, all latest updates as of 02/march/2005, ff1.0, with english
as default language. no themes for ff, but the following extensions that i dont
think will matter but i'll include anyway;
*forecastfox 0.5.9
*tabbrowser preferences 1.1.1
*image zoom 0.1.7

Comment 1

13 years ago
confirming hang/crash 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050301

Before testing I disabled Java and Javascript, didn´t help. 
I also tested it with Mozilla 1.4.2, no crash/hang when JS/Java was disabled.
Mostly it was hanging, twice crashing, Talkback didn´t come up, Windows was
crashing. Win98SE, 512MB
Assignee: other → general
Component: Other → General
Keywords: crash, hang
Product: Tech Evangelism → Mozilla Application Suite
QA Contact: other → general
Version: unspecified → Trunk

Comment 2

13 years ago
wfm Mozilla   1.4.2: 2004042614
crashes Mozilla 1.6: 2004011308
crashes Reporters Firefox 1.0
crashes Mozilla 1.8b2: 2005030105
crashes DOMinspector

I disabled Java, JS, images, popups and it was crashing my Win98SE
I didn´t have flash disabled, and the the files downloaded using 1.4.2 are
containing some flash files. I´ve got Shockwave Flash 7.0 r19

Comment 3

13 years ago
I renamed the plugin folder of Opera, where Flash was installed, and checked
once more, Java, JS, images, popups, prefetch, cookies disabled, about:plugins
was showing the null plugin and Acrobat 5.10 only. No extensions installed.

After crashing windows, I rebooted win98SE, restarted Mozilla, loaded a tabgroup
(appending), then this bug in the first tab, crashed and talkback came up.
Don´t know if it is related to the crashs. The tabgroup was Bugs today,
Tinderbox, checkins.

TB4063446G Stack Signature	 DummyLayoutRequestEvent::HandleEvent 92dd25e6
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB4063446G

some html bugs:
<iframe src=http://wmshop.allweb-search.ru/vxod.htm width=0 height=0
marginwidth=0 marginheight=0></iframe>
<td align="right">&copy Copyright
<td alig="left">


Comment 4

13 years ago
now testing on Win98/128MB RAM
working: 1.4.2: 2004042614
crashing: 1.6a: 2003103019   

Local copy saved as webpage, complete did load fine in 1.8b2: 2005030206
Loading the original URL in another tab was increasing CPU usage to 100% of the
slow Celeron 333, and RAM started rising, so I killed Mozilla using Task manager.
I used LiveHTTPHeaders to see what was loaded, and observed a lot of 404s.
Maybe that makes the difference in loading/crashing of a local copy and a page
loaded from net.

I don´t know what to do next, where this bug belongs to.

It regressed between Mozilla 1.4 and 1.6a
It doesn´t crash or hang on a local copy
It doesn´t need Java, JS, plugins or Extensions to crash
Loading from the internet shows a lot of 404s in Extension LiveHTTPheaders.

Does it belong to Networking, as it can be seen only when loading from the net?
to Parser, as there are more than 100 HTML-Errors?
to CSS, as there are three handful of CSS errors, and two handful of warnings.
Is this bug Windows only, or can it be seen on other OS as well?

Comment 5

13 years ago
There are 6 <iframe> in the page, this one seems to be the culprit:
http://ifboards.ru/vxod.htm

view-source:http://ifboards.ru/vxod.htm is showing three iframes:
http://dvdselect.ru.ru/vxod.htm
http://all-inet.com/top2.htm                         <--- recursion
http://ifboards.chat.ru/vxod.htm

The second calls the parent:
view-source:http://all-inet.com/top2.htm
http://dvdselect.ru/films/vxod.htm
http://ifboards.ru/vxod.htm                          <--- recursion
http://ifboards.chat.ru/vxod.htm
http://wmshop.allweb-search.ru/vxod.htm
http://softbazar.ru/sscript.php


changing summary accordingly:
was: when going to this website with FF1.0 it slowly increases both RAM and CPU
now: recursion in <iframe>s hangs or crashes Mozilla Suite & Firefox

regression: 
Mozilla 1.4.2 is working fine, 1.6a and later is crashing or hanging
Keywords: regression
Summary: when going to this website with FF1.0 it slowly increases both RAM and CPU → recursion with <iframe>s hangs or crashes Mozilla Suite & Firefox

Comment 6

13 years ago
Bug 228829  	Crash on page with recursive frames

Bug 228594 	iframe's should not be allowed to load any parent document, as a
child iframe

Bug 229035  	crash by recursive document writes of script

Bug 272247  	Crash When an Iframe relocates its parent page when page has a
javascript alert up



*** This bug has been marked as a duplicate of 228829 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 7

13 years ago
*** Bug 285951 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.