Closed Bug 284379 Opened 15 years ago Closed 14 years ago

if middlemouse.contentLoadURL is true, middleclicking on a tab opens the clipboard text as url in the active tab rather than the tab you clicked on

Categories

(Firefox :: Tabbed Browser, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 2 alpha1

People

(Reporter: marcldl+mozbugs, Assigned: ispiked)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1 (Marc)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Enabling middlemouse.contentLoadURL should only enable this functionality when
middle clicking over some parts of the browser. The tab box should not be one of
these parts. Middle clicking on a tab should close the tab.

Currently the text on your clipboard is opened in the active tab regardless of
which tab you middle clicked.

This often leads to a Google I'm Feeling Lucky Search for random text you
happened to have copied at the time.

Reproducible: Always

Steps to Reproduce:
1. Enable middlemouse.contentLoadURL in about:config
2. Copy www.exmaple.com to clipboard.
3. Open new tab.
4. Middle click tab

Actual Results:  
www.example.com is opened in active tab

Expected Results:  
Middle clicked tab should be closed
This is lame.  If doesn't even matter which tab you click, it loads in the
current context.

-> me, 1.1
Assignee: bugs → mconnor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Firefox1.1
Status: NEW → ASSIGNED
note to self, dropping the contentLoadURL check in tabbrowser's onTabClick
method is the fix here, do after tab dnd lands.

Rationale is that the current implementation still loads in the current tab
anyway, so we're losing nothing, and gaining a useful feature.
Voted for this as it's *extremely* annoying and in fact took me the best part of
ten minutes to work out why it was taking me to apparently random web pages. Not
intuituve at all. 

Another (perhaps unrelated?) issue I have is when i disable it in about:config,
it returns to the default after firefox is restarted.
(In reply to comment #3)
> Voted for this as it's *extremely* annoying and in fact took me the best part of
> ten minutes to work out why it was taking me to apparently random web pages. Not
> intuituve at all. 
> 
> Another (perhaps unrelated?) issue I have is when i disable it in about:config,
> it returns to the default after firefox is restarted.

I find that, on my Ubuntu installation, if I had this set to false in the beta,
and then I close the beta, open 1.07, close it, and then go back to the beta,
then it gets reset to the default of true.  I'd assume that means that the
default in 1.07 is false then.

Also, just a heads up, you can override the setting in your user.js if this bugs
you, but I haven't tried it myself.

See http://kb.mozillazine.org/User.js_file
Attached patch patchSplinter Review
Assignee: mconnor → ispiked
Attachment #205905 - Flags: review?
mozilla/toolkit/content/widgets/tabbrowser.xml; new revision: 1.123;
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
OS: Linux → All
Resolution: --- → FIXED
Target Milestone: Firefox1.5 → Firefox1.6-
Severity: normal → minor
Version: unspecified → Trunk
Flags: blocking-aviary2?
Attachment #205905 - Flags: approval1.8.1?
This might partially resolve a lot of the bugs complaining about Linux not closing tabs with middle mouse by default...
Attachment #205905 - Flags: approval1.8.1? → approval1.8.1+
Flags: blocking-firefox2? → blocking-firefox2+
Checked in on the 1.8 branch for Firefox 2.
mozilla/toolkit/content/widgets/tabbrowser.xml; new revision: 1.103.2.14;
Keywords: fixed1.8.1
Target Milestone: Firefox 2 → Firefox 2 alpha1
*** Bug 327182 has been marked as a duplicate of this bug. ***
the "bug" is actually the behavior that I want, but I can't get it to work :(
IIRC, the bug here is: "if middlemouse.contentLoadURL is true, middleclicking on a tab opens the clipboard text as url in the active tab rather than the tab you clicked on". 

The "fix" was to disable middlemouse.contentLoadURL totally, so that now *there is no way* to open clipboard text as url with middleclicking. 

The title of this report, not to mention the way it was resolved, has no relation to the actual bug. 
Duplicate of this bug: 376430
Summary: Enabling middlemouse.contentLoadURL and middle clicking a tab should still close tab → if middlemouse.contentLoadURL is true, middleclicking on a tab opens the clipboard text as url in the active tab rather than the tab you clicked on
You need to log in before you can comment on or make changes to this bug.