Closed Bug 284383 Opened 15 years ago Closed 15 years ago

Copying consecutive spaces formated with css whitespace style "pre" collapses spaces.

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 116083

People

(Reporter: justin, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Copying consecutive spaces formated with css whitespace style "pre" collapses
spaces.These spaces render correctly (several in a row in the html file display
several in a row in browser), but when copied to a text editor are colapsed to
just one. Multiple spaces inside the <pre> tags copy correctly.

Reproducible: Always

Steps to Reproduce:
1.load a web page with this code <span style = "white-space:pre;">Blah    
Blah</span>
2.copy the Blah <spaces> Blah
3.paste to text editor

Actual Results:  
The multiple spaces are collapsed to 1. This is not how they appeared in
rendering.(rendering is correct)

Expected Results:  
The multiple spaces that apear in the html, and in the rendering, should be
copied to the text editor.

*** This bug has been marked as a duplicate of 116083 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.