If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Missing library libXp.so.6 on install

RESOLVED WORKSFORME

Status

()

Firefox
Installer
--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Tom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0
Build Identifier: Firefox 1.0.1  (posted for download on the main mozilla website.)

It seems I'm missing a library when trying to install 1.0.1. I'm installing this
on a x86 Fedora Core 3 (Linux) machine with an XFce windowing environment. I am
currently running firefox 1.0 with no problems. Below are my steps I tried for
installation. I'm attempting the install in my /usr/lib/firefox-1.0.1/
directory. The missing library libXp.so.6 is not found on my machine anywhere
(find / -name libXp.so.6).  I've removed firefox 1.0.1 and tried to reinstall 3
times, all with the same results.

[root@netsnoop downloads]# mkdir /usr/lib/firefox-1.0.1
[root@netsnoop downloads]# mv firefox-1.0.1.installer.tar.gz
/usr/lib/firefox-1.0.1/.
[root@netsnoop downloads]# cd /usr/lib/firefox-1.0.1
[root@netsnoop firefox-1.0.1]# ls
firefox-1.0.1.installer.tar.gz
[root@netsnoop firefox-1.0.1]# tar -xzf firefox-1.0.1.installer.tar.gz
[root@netsnoop firefox-1.0.1]# ls
firefox-1.0.1.installer.tar.gz firefox-installer
[root@netsnoop firefox-1.0.1]# cd firefox-installer/
[root@netsnoop firefox-installer]# ls
config.ini firefox-installer-bin install.ini watermark.png
firefox-installer header.png license.txt xpi
[root@netsnoop firefox-installer]# ./firefox-installer
[root@netsnoop firefox-installer]# /usr/lib/firefox-1.0.1/firefox-bin: error while
loading shared libraries: libXp.so.6: cannot open shared object file: No such
file or directory

Reproducible: Always

Steps to Reproduce:
1. Run the install as noted above in the details.
2.
3.

Actual Results:  
/usr/lib/firefox-1.0.1/firefox-bin: error while loading shared libraries:
libXp.so.6: cannot open shared object file: No such file or directory

Expected Results:  
Firefox 1.0.1 should start up.

I've posted a not on the Firefox General board but have not received a response.
 I can't imagine I'm the only one seeing this error.

Comment 1

13 years ago
libXp (client XPrint lib) is in xorg-x11-deprecated

this is really a build config bug (the installer ran fine) although no such
component exists in firefox, or needs to be rel-noted.  But if 1.0 worked, did
it not include Xprint and 1.0.1 does?
Summary: Missing library on install → Missing library libXp.so.6 on install

Comment 2

13 years ago
FYI: my firefox 1.0 is also linked against libXp.so.6

Comment 3

13 years ago
were you running the firefox that came with FC3?
I've seen other people have problems with this (along with the -linc issue,
which I think we fixed, and perhaps one other similar issue).
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> were you running the firefox that came with FC3?

No.  I had upgraded the firefox (0.10?) that came with FC3 to 1.0 using the
default linux distribution that was on the firefox homepage (mozilla.org) and
not via redhat update.  Like I mentioned before, that install was OK. I have
sucessfully updated firefox to 1.0.1 using the latest RPM distribution found at
http://mirror.linux.duke.edu/pub/fedora/linux/core/3/i386/os/Fedora/RPMS/.  It
seems, to me, that the distribution on the firefox homepage might expect a
library not found in Xorg but found in XFree86?  I don't know, I'm not a X
expert by any means. 

Comment 6

13 years ago
The library is still in Xorg, but Red Hat put it in the deprecated-libs package
because not many things use it (within Fedora/Red Hat-distributed packages,
*nothing* uses it) and they are of the opinion that nothing should use it.

Updated

12 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer

Comment 7

10 years ago
Firefox 1.5.0.12 and 2.0.0.4 distributed from Mozilla.com does not
have this library dependency.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.