Copy from moz-text-plain "mangles" (doubles up) quote prefix chars

VERIFIED DUPLICATE of bug 222344

Status

MailNews Core
Backend
VERIFIED DUPLICATE of bug 222344
13 years ago
9 years ago

People

(Reporter: Andy Ross, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922 Epiphany/1.2.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922 Epiphany/1.2.7

Thunderbird 1.0 mangles the content of the message body when it
transfers it to the clipboard or provides it as a selection.  It
doubles the number of ">" quote prefixes and prefixes them to each
line, and inserts an extra newline (with extra quote prefixing)
between every "quote level" boundary.

The following two excerpts illustrate the problem.  The first is the
literal text of a message as it appears on the server and via Ctrl-U.
The second is the text I get if I copy and paste the message into
another application.  The ==== boundaries are simply for readability,
obviously.

I am in the habit of composing my email in an external editor, and
this is an exceedingly annoying bug.  It has been present since at
least Thunderbird 0.6.

== This text: ==========================================================
========================================================================
Someone wrote:
> I responded:
> > Someone wrote:
> > > Blah blah blah
> > 
> > Harumph!
> 
> Blah blah blah

Ugh...
========================================================================

== Gets mangled into this: =============================================
========================================================================
Someone wrote:

>> I responded:
>
>>> > Someone wrote:
>>
>>>> > > Blah blah blah
>>
>>> >
>>> > Harumph!
>
>>
>> Blah blah blah


Ugh...
========================================================================



Reproducible: Always
(Reporter)

Comment 1

13 years ago
Any word on this?  Should I be submitting this somewhere else?

Comment 2

13 years ago
possible dup of bug 114954 ?
can't comment further as I don't have linux nor use an external editor.

You might follow up with the people over in that bug. If you feel this is a dup
then add a comment here and someone can mark it as a dup.
Whiteboard: dupme
(Reporter)

Comment 3

13 years ago
Knock knock?

Note that this isn't a dupe of the bug Wayne linked to.  I'm the repoter of that
one too, and it has a workaround.  This one doesn't.
(Reporter)

Comment 4

13 years ago
And note that you need neither linux nor an external editor to see the bug. 
Just copy a message with quoted text and paste into notepad.exe.
I tested this today using the nightly Win32 build from yesterday.

I used this for testing :
> I responded:
> > Someone wrote:
> > > Blah blah blah
> > 
> > Harumph!
> 
> Blah blah blah

and I cannot duplicate this bug under Windows XP.

Comment 6

12 years ago
I see this when I'm copy a *displayed* message that is text/plain but not 
format=flowed;  TB 1.5b1-0904 and 1.6a1-0904, Seamonkey 1.0-0806.

I do not see this when copying from the compose window.  Moving to backend.
Status: UNCONFIRMED → NEW
Component: Message Compose Window → MailNews: Backend
Ever confirmed: true
OS: Linux → All
Product: Thunderbird → Core
Hardware: PC → All
Summary: Mail editor mangles content on copy/paste → Copy from moz-text-plain "mangles" (doubles up) quote prefix chars
Whiteboard: dupme
Version: unspecified → Trunk

Comment 7

12 years ago

*** This bug has been marked as a duplicate of 222344 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.