Attachement of XML file is sent as Content-Disposition: inline;

RESOLVED DUPLICATE of bug 65794

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 65794
13 years ago
13 years ago

People

(Reporter: Olivier Vit (just a reporter), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050228
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050228

Send an xml file as attachment doesn't ensure that it will be received as an
attachment by other mail clients or webmail application, causing trouble to get
save it back as a file

Reproducible: Always

Steps to Reproduce:
1. Create a new message
2. Attach an xml file
3. send to yourself and view the source of the recieved message

Actual Results:  
From - Thu Mar 03 14:44:01 2005
X-Account-Key: account3
X-UIDL: 1109857012.11667.mrelay3-2
X-Mozilla-Status: 0001
X-Mozilla-Status2: 10000000
Return-Path: <olivier.vit@free.fr>
Delivered-To: online.fr-olivier.vit@free.fr
Received: (qmail 11654 invoked from network); 3 Mar 2005 13:36:52 -0000
Received: from florius.duke-interactive.net (62.39.136.162)
  by mrelay3-2.free.fr with SMTP; 3 Mar 2005 13:36:52 -0000
Received: from aph-aug-103-2-1-4.w193-252.abo.wanadoo.fr ([193.252.201.4]
helo=mail.duke-interactive.com)
	by florius.duke-interactive.net with smtp (Exim 4.44)
	id 1D6qVX-0005oG-AQ
	for olivier.vit@free.fr; Thu, 03 Mar 2005 14:36:52 +0100
Received: from [10.42.10.79] (helo=[10.42.10.79])
	by mail.duke-interactive.com with esmtp (Exim 3.35 #1 (Debian))
	id 1D6qVI-0006h1-00
	for <olivier.vit@free.fr>; Thu, 03 Mar 2005 14:36:36 +0100
Message-ID: <42271387.1010003@free.fr>
Date: Thu, 03 Mar 2005 14:39:19 +0100
From: Olivier Vit <olivier.vit@free.fr>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050228
MIME-Version: 1.0
To: undisclosed-recipients:;
Subject: test xml subject
Content-Type: multipart/mixed;
 boundary="------------020004010100030903070005"
X-Duke-MailScanner: Found to be clean

This is a multi-part message in MIME format.
--------------020004010100030903070005
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

body

--------------020004010100030903070005
Content-Type: text/xml;
 name="listmusee.xml"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline;
 filename="listmusee.xml"

=EF=BB=BF<?xml version=3D"1.0" encoding=3D"utf-8"?>
<!DOCTYPE reply SYSTEM "listmusee.dtd">
<listmusee><musee><nom>Arc de Triomphe</nom><adresse>Place Charles de Gau=
lle, Paris 8e</adresse><resume>Symbole de l=E2=80=99=C3=A9pop=C3=A9e napo=
l=C3=A9onienne, l=E2=80=99Arc de Triomphe offre un panorama exceptionnel =
sur les Champs Elys=C3=A9es et sur Paris.</resume><tel>01 55 37 73 77</te=
l><transport>M=C2=B0ou RER Charles de Gaulle-Etoile</transport><horaire>1=
0h-23h du 1.04 au 30.09, 10h-22h30 du 1.

Expected Results:  
Content-Disposition: attachment;
being used instead
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk

Comment 1

13 years ago
Looks like Bug 65794 (and Bug 66915). Duplicate?
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.