If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Box layout does not provide consistent sizes

VERIFIED DUPLICATE of bug 28460

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 28460
18 years ago
9 years ago

People

(Reporter: rods (gone), Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Box layout is not providing the combobox with a consistent sizes for 
aReflowState.mComputedWidth (or availableWidth). When the mail compose window 
displays the last mComputedWidth size as the the "From" Combobox gets layed 
out it is "4269", then on a mouse down the mComputedWidth is "5022".

The 5022 is an incremental reflow targeted at the ListControlFrame that is a 
child (popup list child so it doesn't get reflowed automatically) of the 
ComboboxControlFrame. In normal HTML layout the incoming mComputedWidth and 
availableWidth are both UNCONSTRAINED.

Here is my debug output:
nsCCF - nsComboboxControlFrame
nsLCF - nsListControlFrame
----------------------------------------------------
OnEndDocumentLoad
03C5F98C ** nsCCF::Reflow 15 R: Resize AW: 4329 AH: UNC CW: 4269 CH: 270 NO: 2 *

**Constrained WW: 4029  HH: 240
DW: 345
03C5FA54 ** nsLCF::Reflow 19 R: Resize AW: 345 AH: UNC CW: 345 CH: UNC
** Done nsLCF DW: 345  DH: 540
[[[[ CW: 4269 30 30
** Done nsCCF DW: 4329  DH: 330
Lost focus.
nsWebShellWindow::GOTFOCUS
set focus on the recipient
WEBSHELL+ = 7
Lost focus.
Lost focus.
nsWebShellWindow::GOTFOCUS
--------------------------- MouseDown ----------------------------
03C5F98C ** nsCCF::Reflow 16 R: Increm AW: 5082 AH: UNC CW: 5022 CH: 270 NO: 2 *

-----------------Target is Dropdown or it's child------------
03C5FA54 ** nsLCF::Reflow 20 R: StyleC AW: UNC AH: UNC CW: UNC CH: UNC
** Done nsLCF DW: 3675  DH: 540
|** Done nsCCF DW: 4329  DH: 330
--------------------------- MouseUp ----------------------------
03C5F98C ** nsCCF::Reflow 17 R: Increm AW: 5082 AH: UNC CW: 5022 CH: 270 NO: 2 *

-----------------Target is Dropdown or it's child------------
03C5FA54 ** nsLCF::Reflow 21 R: StyleC AW: UNC AH: UNC CW: UNC CH: UNC
** Done nsLCF DW: 3675  DH: 540
|** Done nsCCF DW: 4329  DH: 330
--------------------------- MouseUp ----------------------------
Lost focus.
(Reporter)

Comment 1

18 years ago
Problems with bugzilla - I couldn't tell if I had submitted it or not

*** This bug has been marked as a duplicate of 28460 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
duplicate entry of bug report. marking verified duplicate.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: paulmac → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.