Closed Bug 284824 Opened 15 years ago Closed 14 years ago

Display page title normally in popup window title bar if popup's host matches parent window's host, even if popup's address bar is hidden

Categories

(Firefox :: General, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jfleshman, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

While creating a mini-web app for myself, I noticed that since I hide the
address bar in the popup window I use FF decides that I'm probably phishing and
displays the host and port of my server before the page title in the popup's
title bar. While this is a good idea 90-some percent of the time, when the host
of the popup matches the host of the window that opened it (as is the case for
what I'm doing) I think the page title should display normally. As it is now,
the host name prevents the page title from displaying in my taskbar; if the
window isn't up front I tend to mistake its taskbar entry for a view-source window.

Reproducible: Always

Steps to Reproduce:
1. Go to www.jasonfleshman.org/moz/popuptest
2. Click the "Launch" link

Actual Results:  
The window's title is "http://www.jasonfleshman.org - Popup Tester II - Mozilla
Firefox"

Expected Results:  
The window's title is "Popup Tester II - Mozilla Firefox" since both the popup
and the page that launched it are from jasonfleshman.org
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050228
Firefox/1.0+

Try clearing the browser cache, it is possible that a version without a title is
cached.
(Fixing a typo in the summary since I'm adding a comment anyway)

No, the title of the page shows up after the hostname for me -- if it were a
cache issue it'd be the full URL, not just the host. Also, the test case I
linked to didn't exist until right before I filed the bug, so there would be no
cache entry for me to use. Maybe it's only on the 1.0.1 branch and not in the
nightlies?
Summary: Display pape title normally in popup window title bar if popup's host matches parent window's host, even if popup's address bar is hidden → Display page title normally in popup window title bar if popup's host matches parent window's host, even if popup's address bar is hidden
Correct, it's only on the 1.0.1 branch.  See bug 22183 comment 253.
Yes - we're working on a better solution for the trunk so hopefully the titlebar
change won't go into Firefox 1.1.

Gerv 
(In reply to comment #4)
> Yes - we're working on a better solution for the trunk so hopefully the titlebar
> change won't go into Firefox 1.1.
> 
> Gerv 

I hope it will happen very soon, because this bug really annoys me. Beyond this
I enjoy using Firefox, it's a great product!
Len
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
WONTFIX: the purpose of including the hostname in the titlebar is to prevent web
pages from spoofing browser chrome, so leaving it out based on whether it
matches the parent's hostname doesn't make any sense.  As Gerv said, we're
thinking about other solutions that don't involve putting the hostname in the
titlebar.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX

14 years later and it's still like this. Must be a very hard problem that a proper solution still hasn't been found to stop this bad-UX kludge. 🤨

It doesn't matter what the URL looks like to the user, the browser sees the raw bytes and can tell the difference between youtube.com and yоutube.com with a Cyrillic o and could react appropriately if necessary (eg changing the icon in the titlebar of the popup window instead of messing with the title, which actually makes things worse since it pushes the title out of sight if the window isn't large enough).

As for UI-spoofing, how about simply separating the actual content from the chrome by putting a thin border around it. Maybe that's what the unexplained 1-pixel black line from bug 1530045 is. 🤔

You need to log in before you can comment on or make changes to this bug.