Quick Search seems to be case-sensitive for non-ascii characters

RESOLVED DUPLICATE of bug 284856

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 284856
13 years ago
10 years ago

People

(Reporter: Sebastian von Knorring, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217

Quick Search seems to be case-sensitive for umlauted characters, while
case-insensitive for normal ASCII characters (a-z, A-Z).

When I use Quick Search ("Subject or sender contains") for searching for
messages, I need to perform the search twice when the word I search for contains
umlauted characters (or perhaps also accented characters, haven't tested).

Example:

When I search for "aly", it matches both "aly" and "Aly".
When I search for "Aly", it matches both "aly" and "Aly".

That's OK.

When I search for "äly" (a with an umlaut: ä), it matches only "äly".
When I search for "Äly" (A with an umlaut: Ä), it matches only "Äly".

That's not OK, since I have to search twice.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Darn, this seems to be a duplicate of bug 284856. Sorry for the spam, I tried to
search for duplicates but came up with nothing.

Comment 2

13 years ago
Do you have IMAP? =)
URL: n/a
Severity: minor → normal
(Reporter)

Comment 3

13 years ago
Yes. I was referring to searches in IMAP folders.

Comment 4

13 years ago
So, let's mark it as dupe for now. Please reopen, if bug 284856 will be fixed
and you'll still see this bug.

*** This bug has been marked as a duplicate of 284856 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: search
You need to log in before you can comment on or make changes to this bug.