UI: Add visual cue as to which pane the focus is in



MailNews: Message Display
18 years ago
14 years ago


(Reporter: Richard Zach, Assigned: andreww)




Firefox Tracking Flags

(Not tracked)


(Whiteboard: [nsbeta3+][fix ready])


(1 attachment)



18 years ago
The arrow keys can be used in all three mail panes (switch folders/accounts in
folder pane, switch message in thread pane, scroll message in message pane).
However, there is no visual cue as to which pane has focus, so the user doesn't
know what to expect when she clicks Up or Down. (NS 4.7 had added an outline
around the folder and thred pane if you clicked in it).

Comment 1

18 years ago
I think hangas was working on this a while back. Paul?
Assignee: phil → hangas

Comment 2

18 years ago
Ah yes, an old favorite of mine.  I have the blessing of UE to add a rectangle 
around each of these panes.  There are still bugs that prevent this from working 
perfectly but I will see if I can get it working partially.  Upgrading from 
enhancement to normal severity.
Severity: enhancement → normal
Keywords: polish
Target Milestone: M15


18 years ago
QA Contact: lchiang → nbaca
Summary: Add visual cue as to which pane the focus is in → UI: Add visual cue as to which pane the focus is in

Comment 3

18 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16

Comment 4

18 years ago
Not beta2 stopper.  Marking M18.  Please let me know if you disagree.
Target Milestone: M16 → M18

Comment 5

18 years ago
hmm, this bug should no longer be assigned to hangas.  reassign to putterman.
Assignee: hangas → putterman

Comment 6

18 years ago
we have another bug to make sure the selection is showing focus correctly(blue
or grey).  I think we can live without this for this release. moving to future
Target Milestone: M18 → Future

Comment 7

18 years ago
I am not clear on the last comment from putterman.  Are we saying that this is a 
duplicate of another bug or that this will not be in for RTM.  This is must have 
functionality for RTM in the opinion of the UI group.  So if there is another bug 
that is open to fix this issue please point me at it, otherwise I nominate this 
one for nsbeta3 and remove the future milestone.  This is on the "Must Fix List" 
from UI Eng.  If MailNews is unable to fix this critical UI issue please send it 
to me so that I can plus it and borrow an engineer to fix it.
Keywords: nsbeta3
Target Milestone: Future → ---

Comment 8

18 years ago
my comments referred to the fact that in both the address book and mail window,
you can't tell which pane has focus because both the thread pane and folder pane
selection are dark blue (compared to light grey for the disabled one and blue
for the selected one). We have a bug to fix this fact.

I belive we can live without the focus rectangle.

Comment 9

18 years ago
Mail triage is giving this an nsbeta3-.  Paul if you guys want to fix this
please take the bug.
Whiteboard: [nsbeta3-]

Comment 10

18 years ago
Taking bug.  This is a must fix.  Marking nsbeta3.  Showing a blue vs gray 
selection is not enough because it is possible to not be focused on either tree 
in which case there is no way to tell what is going on because both trees would 
show a gray selection.
Assignee: hangas
Whiteboard: [nsbeta3-] → [nsbeta3+]
Target Milestone: --- → M18

Comment 11

18 years ago
Taking bug at behest of Paul.  Starting work on it right now.
Assignee: hangas → andreww

Comment 12

18 years ago
I have a potential fix for this ready. I'd like to review it with Paul  before I 
check it in.


18 years ago
Keywords: mailtrack

Comment 13

18 years ago
Created attachment 14002 [details] [diff] [review]
diffs for implementing 3 pane focus on mail

Comment 14

18 years ago
I posted the diffs for implementing a 3 pane view (with css for modern as an 

Could someone review this and let me know if this is a good enough fix for this?
No evil css (Hyatt).


18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+][fix ready]

Comment 15

18 years ago
ok, finally checked this in. I can finally mark this fixed.
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
there are still issues with this bug - other cases and things like getting it to 
work properly on Classic.  Instead of this bug living forever, please file new 
bugs on those issues.

Comment 17

18 years ago
Build 2000-09-13-08M18: NT4, Linux 6.0, Mac 9.04
Verified Fixed. 
I will log seperate bugs on specific issues (i.e. Focus Ring not obvious in 
Thread pane using Classic)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.