Closed Bug 285561 Opened 19 years ago Closed 19 years ago

Cache leads to user data loss

Categories

(Firefox :: General, defect)

x86
Windows ME
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 74085

People

(Reporter: idealist, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

This bug should be treated most seriously. Firefox use can lead to data loss (as
it did in my case:( because the very frequent disk writes to the folder 'Cache'
are made to the same partition table and indeed the same folder as user
documents and settings (with bad luck one can therefore lose the entire
'Documents and Settings' folder..) Cache should be immediately moved to
TEMPorary folder, whose path should be determined by either a system variable or
the location of paging file. Additionally, the cache folder location should be
controlled manually, like in Mozilla.

Reproducible: Always

Steps to Reproduce:
Just surfed with background writes to a 150 MB database...
Actual Results:  
Scandisk found a cross-link with one of the Firefox cache files - unreadable both :(

Expected Results:  
Written cache info to the TEMP folder, which is safely located on another "junk"
partition, together with the paging file.
The Disk cache should be in the local directory and this will happen.
If you want to chnage the location you have to use about:config

*** This bug has been marked as a duplicate of 74085 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.