In <globalOverlay.js>, (2) "Warning: function goQuitApplication does not always return a value"

RESOLVED FIXED in mozilla1.8beta2

Status

()

--
trivial
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
mozilla1.8beta2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
[Mozilla Thunderbird, version 1.0.1 (20050309)] (nightly) (W98SE)

{{
Warning: function goQuitApplication does not always return a value
Source File: chrome://global/content/globalOverlay.js
Line: 64, Column: 19
Source Code:
       return false;          

Warning: function goQuitApplication does not always return a value
Source File: chrome://global/content/globalOverlay.js
Line: 68, Column: 13
Source Code:
  return true;
}}
(Assignee)

Comment 1

14 years ago
Created attachment 177009 [details] [diff] [review]
(Av1) <globalOverlay.js>
[Checked in: Comment 3]

Came from
{{
1.7	ben%bengoodger.com	2003-11-30 21:40		Ensure that
window closing that would cause the app to quit goes through the same codepath
as an actual application quit. (The bug was that you would get the download
cancel confirmation prompt when shutting down via File->Exit, but not when you
closed all windows)
}}

Could you (super-)review/check in this patch ? Thanks.
(Assignee)

Updated

14 years ago
Assignee: events → gautheri
Status: NEW → ASSIGNED
Attachment #177009 - Flags: superreview?(bryner)
Attachment #177009 - Flags: review?(bryner)
Comment on attachment 177009 [details] [diff] [review]
(Av1) <globalOverlay.js>
[Checked in: Comment 3]

r+sr=bryner
Attachment #177009 - Flags: superreview?(bryner)
Attachment #177009 - Flags: superreview+
Attachment #177009 - Flags: review?(bryner)
Attachment #177009 - Flags: review+
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Attachment #177009 - Attachment description: (Av1) <globalOverlay.js> → (Av1) <globalOverlay.js> [Checked in: Comment 3]
Attachment #177009 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Target Milestone: --- → mozilla1.8beta2
*** Bug 290356 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Attachment #177009 - Attachment is obsolete: false
You need to log in before you can comment on or make changes to this bug.