Rendering poorly, when the HTML is a bit broken (tags parameter not closed correctly).

RESOLVED DUPLICATE of bug 47755

Status

()

--
minor
RESOLVED DUPLICATE of bug 47755
14 years ago
14 years ago

People

(Reporter: priit, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

there comes a nasty rendering error when you are sloppy and forget to end the
tag's parameter with " if you started one with it and it actually waits for the
next " to appear anywhere in the following script.

this script:
<IMG SRC="avatar.gif"><IMG SRC="avatar.gif">
<BR>
<IMG SRC="avatar.gif><IMG SRC=avatar.gif">

shows me 2 avatar.gif-is in first row and in second row I get one erronous
picture which is trying to show me "avatar.gif><IMG SRC=avatar.gif" as a picture.

Reproducible: Always

Steps to Reproduce:
1. write HTML code.
2. start one parameter with " and forget to end it with it, like:
<IMG SRC="avatar.gif>


Actual Results:  
the result in browser is just not right...

Expected Results:  
I do believe that the correct way for it to work would be that the ending of tag
itself '>', should end every open parameter for the current tag.
(Reporter)

Updated

14 years ago
Component: View Source → General
OS: Windows XP → All
Hardware: PC → All
Component: General → HTML: Parser
Product: Firefox → Core
Version: unspecified → Trunk

Comment 1

14 years ago
Could you attach a testcase (or provide a url) which shows the problem.

Comment 2

14 years ago
probably either WONTFIX or dup of bug 47755 (see comment 10 there).

Updated

14 years ago
Assignee: bugs → parser
QA Contact: view-source → mrbkap
Yeah, this is a DUPE. Also consider embedding javascript within attributes
(which could potentially have >s in it).

*** This bug has been marked as a duplicate of 47755 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.