If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need to handle non-installable .JAR's better

VERIFIED DUPLICATE of bug 2855

Status

Core Graveyard
Installer: XPInstall Engine
P1
major
VERIFIED DUPLICATE of bug 2855
21 years ago
2 years ago

People

(Reporter: John Giannandrea, Assigned: dveditz)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

21 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #62432
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=62432
Imported into Bugzilla on 02/03/99 10:48)

If you click on a .jar file and its not an ASD file you get a
dialog that says:

SmartUpdate failed: JAR archive is missing an installer file %s.

Since there will be many more jar files in the world than ASD installers
(signed scripts, most java programs) users will come across these files
frequently and this is a confusing user message.

Bug #59454 (making the Windows association for JAR files be Navigator
by default depends on this being fixed).

-jg

Comment 1

21 years ago
I'll change the wording to anything you'd like, just give me the text.
In the future, we'll be smarter about this.
(Reporter)

Comment 2

21 years ago
Scott can come up with good English...

Comment 3

21 years ago
Per Aleks request, this goes back to jg. Aleks doesn't think the change
will be allowed. Below are my wording suggestions:

A similar dialog in Navigator says: "Unable to launch application. The
application was not found."

So, this dialog might read: "Smart Update unable to launch Java file. A
necessary component was not found."

If more appropriate, you could swap some other text for 'Java file' or
'necessary component'. For example, an alternative might be "SmartUpdate unable
to launch file. The file's type was not recognized."
(Reporter)

Comment 4

21 years ago
Aleks, if you want to later this bug thats up to you, but you know
that I think its just wrong to ship soemthing this broken.
But assigning the bug to me just because you dont care enough to argue
for it is ludicrous.  Its not my bug, I didnt create it!
-jg

Comment 5

21 years ago
I'm adding myself to the cc: list.

Comment 6

21 years ago
4.0 Windows has shipped. Verified LATER.
(Assignee)

Comment 7

20 years ago
We need to deal with non-SmartUpdate .JAR's better. New MIME type and
extension? Re-think the issue for 5.0
(Assignee)

Comment 8

20 years ago
Oops, not a "5.0 SF1" stopper

Comment 9

19 years ago
Moving all Bugsplat bugs for 5.0 to Bugzilla.  dveditz, do you still want this
moved over for a reminder, or can I close this bug?
(Assignee)

Comment 10

19 years ago
Please carry this one over to 5.0

Comment 11

19 years ago
This bug has been moved over to Bugzilla.  It has a Bugzilla id of 2855
(http://bugzilla.mozilla.org/show_bug.cgi?id=2855)

Updated

19 years ago
Component: SmartUpdate → XPInstall
Version: other → 1998-03-31

Comment 12

19 years ago
Moving to XPInstall component.

Comment 13

19 years ago
testing bugzilla account ...

Comment 14

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine

Comment 15

17 years ago
looks like this was imported twice..
Status: CLOSED → REOPENED

Comment 16

17 years ago

*** This bug has been marked as a duplicate of 2855 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
This was addressed in Bug 2855.  Marking Verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.