Closed Bug 28587 Opened 20 years ago Closed 20 years ago

Link retains border after I tab to another link

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 18579

People

(Reporter: mpt, Assigned: cbegle)

Details

Build: 2000021608, MacOS 8.6
(and all Win32 nightlies I tried during November--February, too)

This has probably been reported already, but I can't find it.

To reproduce:
* Go to any page with more than one link on it (such as http://www.mozilla.org/).
* Click on a link, dragging off the link before letting go of the mouse button.
* Note the dotted border which has appeared around the link, signifying that the
  link now has keyboard focus.
* Press Tab. Or click on another link on the same page, again dragging off the
  link before letting go of the mouse button.

What should happen:
* The second link gets a dotted border, and the first link loses its border.

What actually happens:
* Both links retain their borders.
As far as I can see, no link ever loses it's dotted border after getting it. 
If I tab a lot all links passed have the border.

Even if I force a redraw by minimizing and restoring the window the dotted 
borders are there. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a dup of bug 18579 - Link outlines aren't redrawn correctly when
'unselected'. Changing component to Layout and marking duplicate.


*** This bug has been marked as a duplicate of 18579 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Component: Browser-General → Layout
Resolution: --- → DUPLICATE
Verified dup. Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.