Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 129726
13 years ago
12 years ago

People

(Reporter: Michal Poltyn, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Opera/7.54 (Windows NT 5.1; U)  [en]
Build Identifier: 

I am a member of Polish Project of Free Encyclopaedia, Wikipedia. In our site 
there are pages needs our polish letters, like 'ą' or 'ó'. Wikipedia works good 
only with UTF coding URLs and Firefox always sends URLs in ISO. Can you add this 
option to next version of FF? Opera has this option to sending URLs in UTF 
instead ISO.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050312
Firefox/1.0+

Comment 2

13 years ago
Seems to be WFM with FF 1.0.1.  The characters seem to be escaped fine, for
example clicking "Nauki ścisłe" takes me to:

http://pl.wikipedia.org/wiki/Nauki_%C5%9Bcis%C5%82e

This seems to be the correct page (no Polish spoken!).  

Comment 3

13 years ago
Is this related at all to bug 105909?
(Reporter)

Comment 4

13 years ago
yes, it is related to this bug.

"example clicking "Nauki ścisłe" takes me to:"
Yes, by clicking. But I want to type polish letters on address bar. It is 
unpractical to use Wikipedia if encoding of sended address is not encoded by 
UTF-8. I think it is simple to do in Preferences dialog combo box, which changes 
encoding of sended address.

Comment 5

13 years ago
(In reply to comment #0)

It seems firefox's implementation of URL handing is against the recommendations
by W3C to _always_ send URLs as UTF-8.

Here's a link to the recommendation (for HTML, could not found similar for XHMLT):
http://www.w3.org/TR/html4/appendix/notes.html#non-ascii-chars

Granted the recommendation does not speek of URLs typed into the browsers
location/address bar, but surely it would be stupid to have two types of urls:
those typed in (encoded with random charset) and those from other html documents
(always in UTF-8 says the recommendation).

I.e. there should be no difference whether the URL is typed in to the location
bar or it is from a document of UTF-8 or other (ISO-8859-1) encoding. When sent
over wire, it should be UTF-8 encoded.

At the moment at least URLs written to the Location bar are converted to some
non-UTF-8 enconding (ISO-8859-1 on my WinXP platform?). 

For a working reference, see IE and other modern browsers (pun intended).
(Reporter)

Comment 6

12 years ago
IE converts links in UTF, Opera converts link. Both in Win XP and Mac OS X... (Well, Mac OS have UTF implemetation in itself ;)) Firefox either on Mac OS and Windows can not encode properly those URLs. I don't use Safari much, but as I can remember this browser also can't encode URLs correctly.

--
Michal Poltyn
< holek@irc.pl >

Comment 7

12 years ago
This sounds like an exact dupe of bug 129726. Since latter has been resolved as fixed before this bug was reported, I won't set the dupe just yet. Please comment and also re-confirm the bug with current builds.

Many thanks, Cigno

Comment 8

12 years ago

*** This bug has been marked as a duplicate of 129726 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.