multiple select boxes on the print.html page do not display with borders

VERIFIED WORKSFORME

Status

()

Core
Layout
P2
major
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: ryaker, Assigned: av (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #336863
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=336863
Imported into Bugzilla on 02/03/99 12:07)

problem submitted by david meister, david.meister@nationsbank.com, 904 987-6604

***12:25 12/4/98***kemp***
customer submitted the following description about the developement problem they
are facing.
the "problem" code has also been included:

Borders not drawing correctly

The multiple select boxes on the print.html page do not display with borders
around them.  It appears that Netscape is not redrawing them correctly because
switching to another application, forcing a refresh, displays the select boxes
correctly.  However, once they are displayed correctly, the frame containing
them will not receive any input.  Neither the keyboard nor the mouse work in
this frame from that point forward.  This will prevent people from printing in
Netscape.

<html>

<head>
<meta name="GENERATOR" content="Microsoft FrontPage 3.0">
<meta http-equiv="Pragma" content="no-cache">
<meta http-equiv="Cache-Control" content="no-cache">

<SCRIPT LANGUAGE="JAVASCRIPT"><!--
        function loadPage( pageName ){
                if(formValidate()) {
                        document.forms[0].toPage.value = pageName;
                        document.forms[0].submit();
                }
        }

        function updateEvent(item) {
                if(formValidate()) {

document.forms[0].toPage.value=document.forms[0].fromPage.value;
                        document.forms[0].submitAction.value=item;
                        document.forms[0].submit();
                }
        }

        function setBooleanFromCheckbox(fromfield, tofield) {
                if(fromfield.checked) {
                        tofield.value='1';
                } else {
                        tofield.value='0';
                }
        }

// -->
</SCRIPT>

<title>Print Screen</title>
<script language="JavaScript"><!--
function formValidate() {
        return true;
}

function addItems(field){
        var form = window.document.forms[0];
        var choiceSize = form.dlbReportChoices.options.length;
        var selectSize = form.dlbReportsSelected.options.length;
        var choiceIndex = form.dlbReportChoices.selectedIndex;
        if (choiceIndex >= 0){
                for (var choiceIndex = 0; choiceIndex < choiceSize ;
choiceIndex  ){ //cycle through items selected
                        if
(form.dlbReportChoices.options[choiceIndex].selected){
                                form.dlbReportsSelected.options[selectSize] =
new
Option(form.dlbReportChoices.options[choiceIndex].text);

form.dlbReportsSelected.options[selectSize].value =
form.dlbReportChoices.options[choiceIndex].value;
                                selectSize = selectSize   1;
                                form.dlbReportChoices.options[choiceIndex].value
= "delete"; // mark item for deletion
below
                        }
                }
                var deleteIndex = 0;
                while ((form.dlbReportChoices.options.length != 0) &&
                                (deleteIndex <
form.dlbReportChoices.options.length)){ // while list is not empty or at end
of list
                        if (form.dlbReportChoices.options[deleteIndex].value ==
"delete"){ // cycle through items to remove
from list
                                form.dlbReportChoices.options[deleteIndex] =
null;
                        }
                        else {
                                deleteIndex = deleteIndex   1  ;
                        }
                }
        }
}

function removeItems(field){
        var form = window.document.forms[0];
        var choiceSize = form.dlbReportChoices.options.length;
        var selectSize = form.dlbReportsSelected.options.length;
        var selectIndex = form.dlbReportsSelected.selectedIndex;
        if (selectIndex >= 0){
                for (var selectIndex = 0; selectIndex < selectSize ;
selectIndex  ){ //cycle through items selected
                        if
(form.dlbReportsSelected.options[selectIndex].selected){
                                form.dlbReportChoices.options[choiceSize] = new
Option(form.dlbReportsSelected.options[selectIndex].text);
                                form.dlbReportChoices.options[choiceSize].value
=
form.dlbReportsSelected.options[selectIndex].value;
                                choiceSize = choiceSize   1;

form.dlbReportsSelected.options[selectIndex].value = "delete"; // mark item for
deletion
below
                        }
                }
                var deleteIndex = 0;
                while ((form.dlbReportsSelected.options.length != 0) &&
                                (deleteIndex <
form.dlbReportsSelected.options.length)){ // while list is not empty or at
end of list
                        if (form.dlbReportsSelected.options[deleteIndex].value
== "delete"){ // cycle through items to
remove from list
                                form.dlbReportsSelected.options[deleteIndex] =
null;
                        }
                        else {
                                deleteIndex = deleteIndex   1  ;
                        }
                }
        }
}

function removeAll(field){
        var form = window.document.forms[0];
        var choiceSize = form.dlbReportChoices.options.length;
        var selectSize = form.dlbReportsSelected.options.length;
        var choiceIndex = form.dlbReportChoices.selectedIndex;

        for (var selectIndex = 0; selectIndex < selectSize ; selectIndex  ){
                form.dlbReportChoices.options[choiceSize] = new
Option(form.dlbReportsSelected.options[selectIndex].text);
                form.dlbReportChoices.options[choiceSize].value =
form.dlbReportsSelected.options[selectIndex].value;
                choiceSize = choiceSize   1
        }
        while (form.dlbReportsSelected.options.length != 0){
                form.dlbReportsSelected.options[0] = null;
        }
}

function submitPrintJob(form) {
        if( form.dlbReportsSelected.length == 0 ) {
                alert('Please select at least one document to print');
                return;
        }
        form.joblist.value=form.dlbReportsSelected.options[0].value;
        for(i=1;i<form.dlbReportsSelected.length;i  ) {

form.joblist.value=form.joblist.value ';' form.dlbReportsSelected.options[i].val
ue;
        }
        updateEvent('print');
}

/* Clear the appnavframe for print */
//parent.appnavframe.document.open();
//parent.appnavframe.document.writeln('<HTML></HTML>');
//parent.appnavframe.document.close();

// --></script>
</head>

<body bgcolor="#FFFFFF" text="#000000">

<OBJECT WIDTH=1 HEIGHT=1 ID="nb"
        CLASSID="clsid:733C88E2-3B82-11D2-9642-0000F67C6763"
        CODEBASE="/CFT/install/NBPrint.cab"
        BORDER=0><EMBED type=application/NBPrintPlugIn name="nb" width=1
height=1>
</OBJECT>



<form METHOD="POST" onSubmit="return checkReqdValues(this);"
name="frmPrintScreen"
action="/cgi-bin/gx.cgi/GUIDGX-{b175eb50-51bc-11d2-9489-0000f67c6763}">

        <input type="hidden" name="fromPage" value="print">
  <input type="hidden" name="toPage" value="">
        <input type="hidden" name="submitAction" value="update">
        <input type="hidden" name="joblist" value="">

<div align="center"><center><h2><font face="Arial" size="5"><strong>Print
Closing Documents</strong></font></h2>
  </center></div><div align="center"><center>
        <table border="0" cellpadding="0" cellspacing="1" width="50%">
    <tr>
      <td width="33%" valign="bottom" align="left" nowrap><div
align="center"><center><h4>Available
      Documents</h4>
      </center></div></td>
      <td width="33%" align="left" valign="bottom" nowrap></td>
      <td width="34%" valign="bottom" align="left" nowrap><div
align="center"><center><h4>Selected
      Documents</h4>
      </center></div></td>
    </tr>
    <tr>
      <td width="33%" valign="top" align="left" nowrap>
                        <select name="dlbReportChoices" size="15" multiple>

                                <OPTION VALUE="1">FL0104NC-Statement of
Anti-Coercion</OPTION>

      </select></td>
      <td width="33%" align="center"><input type="button" value="    Add    "
name="BtnAdd"
      onClick="addItems(this);"><div align="center"><center><p><input
type="button"
      value="Remove" name="BtnRemove" onClick="removeItems(this);"></p>
      </center></div><p><input type="button" value="Remove All"
name="BtnRemoveAll"
      onClick="removeAll(this);"></p>
      <p>&nbsp;</td>
      <td width="34%" valign="top" align="left" nowrap><select
name="dlbReportsSelected"
      size="15" multiple>

                                <OPTION VALUE="6">MU0101NC-Good Faith
Estimate</OPTION>

                                <OPTION VALUE="8">MU0103NC-TIL
Truth-In-Lending</OPTION>

      </select></td>
    </tr>
    <tr>
      <td width="33%"></td>
      <td width="33%" align="center"></td>
      <td width="34%"></td>
    </tr>
  </table>
  </center></div><div align="center"><center><p>
        <input type="BUTTON" value="   Print   " name="btnPrint"
onClick="submitPrintJob(this.form)">&nbsp;&nbsp;&nbsp;
        <input type="BUTTON" value="    Done    " name="btnDone"
onClick="updateEvent('done')"></p>
  </center></div><p>&nbsp;</p>
</form>
</body>
</html>
(Reporter)

Comment 1

19 years ago
Rendering issue, probably will be latered to 5.0

------- Status Summary updated by ryaker  12/08/98 12:04 -------

Reproduces as described by customer, transfering to defect

Comment 2

19 years ago
Sounds like layout or FE. Starting this with nisheeth...

Comment 3

19 years ago
Accepting bug.  Starting to take a look...

Comment 4

19 years ago
As soon as I comment out the OBJECT tag definition, the page displays the select
elements properly.  The OBJECT tag definition includes an EMBED tag within it
that instructs the browser to load a plugin titled "NBPrintPlugin".  I don't
have the plugin on my local drive and I couldn't find it on the Netscape plugins
web page.  Please ask the customer to send me the plugin so that I can
investigate this problem further.

Comment 5

19 years ago
I spoke to David Meister of NationsBank today and he has independently come up
with a workaround to this problem.  The problem had to
do with setting the width and height of the plugin on the page to 1.  As soon as
he set it to a different number, everything worked fine.  He is
happy with this workaround.  I'm changing the target fix version to 5.0 so that
we can make sure that we do not re-introduce this problem in
the new NGLayout based browser.

Comment 6

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
Priority: P1 → P2
Summary: multiple select boxes on the print.html page do not display with borders → multiple select boxes on the print.html page do not display with borders

Comment 7

19 years ago
Changing priority to P2...

Updated

19 years ago
Assignee: nisheeth → amusil
Status: ASSIGNED → NEW

Comment 8

19 years ago
Alex, I'm assigning this to you coz its plugin related.  This was a bug reported
in Nav 4.5 and is around in Bugzilla so that we do not re-introduce the bug in
Nav 5.0.

Updated

19 years ago
Assignee: amusil → av
Target Milestone: M10
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Target Milestone: M10 → M11

Comment 9

18 years ago
m10 is over. -> m11.

what is the latest status on this bug?  is work in progress?
(Assignee)

Comment 10

18 years ago
I do not see the described problem any more. In fact, the page behaves the same
with object tag commented out. Can anybody confirm the problem is gone/remains?
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
Based on the original problem, the select boxes are rendered with borders with
Oct 1 build. Marking as verified works for me.
You need to log in before you can comment on or make changes to this bug.