Platform and OS lose their hyperlinks (in create) when viewing

RESOLVED FIXED in Bugzilla 4.4

Status

()

--
trivial
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: sweisberg, Assigned: sjoshi)

Tracking

unspecified
Bugzilla 4.4
Bug Flags:
approval +
approval4.4 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 

When entering a new bug (enter_bug.cgi), "Platform" and "OS" are hyperlinks to 
page.cgi, while when viewing a bug (show_bug.cgi) they no longer are while 
other fields remain as links. 

Reproducible: Always

Updated

13 years ago
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 1

6 years ago
QA Contact field, also has the same problem.

Please assign this bug to me.
Assignee: create-and-change → joshi_sunil
(Assignee)

Comment 2

6 years ago
While fixing this issue I got confused, how we need to implement it?
As of now, different fields are displayed differently,
one option to get a tool tip mouse icon (e.g. Product and component)
and other option is get those field name as hyper links itself(Importance and Assigned to)

Please let me know the approach we need to follow in this case.

Comment 3

6 years ago
We should be using bug/field-label.html.tmpl everywhere.
(Assignee)

Comment 4

6 years ago
Created attachment 675860 [details] [diff] [review]
Patch-v1

Fixed for Version, platform and QA contact field, there is no *OS* label field in view bug page.
Attachment #675860 - Flags: review?(LpSolit)
Comment on attachment 675860 [details] [diff] [review]
Patch-v1

Review of attachment 675860 [details] [diff] [review]:
-----------------------------------------------------------------

Need to include the accesskeys for fields that still have them at least. Can fix on commit.

r=dkl

::: template/en/default/bug/edit.html.tmpl
@@ +269,5 @@
>      [%# PLATFORM #%]
>      [%############%]    
>      <tr>
> +      [% INCLUDE "bug/field-label.html.tmpl"
> +        field = bug_fields.rep_platform editable = 1 %]

accesskey = 'h'

@@ +411,5 @@
>  
>      [% IF Param('useqacontact') %]
>      <tr>
> +      [% INCLUDE "bug/field-label.html.tmpl"
> +        field = bug_fields.qa_contact editable = 1 %]

accesskey = 'q'
Attachment #675860 - Flags: review+

Updated

6 years ago
Flags: approval?
Flags: approval4.4?
Comment on attachment 675860 [details] [diff] [review]
Patch-v1

Review of attachment 675860 [details] [diff] [review]:
-----------------------------------------------------------------

Actually please submit a new patch that has the accesskey fixes as well as fixes the Whiteboard label and I will review that.

::: template/en/default/bug/edit.html.tmpl
@@ +269,5 @@
>      [%# PLATFORM #%]
>      [%############%]    
>      <tr>
> +      [% INCLUDE "bug/field-label.html.tmpl"
> +        field = bug_fields.rep_platform editable = 1 %]

accesskey = 'h'

@@ +411,5 @@
>  
>      [% IF Param('useqacontact') %]
>      <tr>
> +      [% INCLUDE "bug/field-label.html.tmpl"
> +        field = bug_fields.qa_contact editable = 1 %]

accesskey = 'q'
Attachment #675860 - Flags: review+ → review-
(Assignee)

Comment 7

6 years ago
Created attachment 675928 [details] [diff] [review]
Patch-v2

Fixed Access key for QA Contact and Hardware and handled whiteboard case also.
Attachment #675860 - Attachment is obsolete: true
Attachment #675860 - Flags: review?(LpSolit)
Attachment #675928 - Flags: review?(dkl)

Updated

6 years ago
Flags: approval?
Flags: approval4.4?
Comment on attachment 675928 [details] [diff] [review]
Patch-v2

Review of attachment 675928 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good other than nit which I can fix on checkin. r=dkl

::: template/en/default/bug/edit.html.tmpl
@@ +270,5 @@
>      [%############%]    
>      <tr>
> +      [% INCLUDE "bug/field-label.html.tmpl"
> +        field = bug_fields.rep_platform editable = 1
> +        accesskey = "h" %]        

nit: each on its own line

 [% INCLUDE "bug/field-label.html.tmpl"
    field = bug_fields.rep_platform 
    editable = 1
    accesskey = "h" 
  %]

@@ +412,5 @@
>      [% IF Param('useqacontact') %]
>      <tr>
> +      [% INCLUDE "bug/field-label.html.tmpl"
> +        field = bug_fields.qa_contact editable = 1
> +        accesskey = "q" %]

same
Attachment #675928 - Flags: review?(dkl) → review+

Updated

6 years ago
Flags: approval?
Flags: approval4.4?

Updated

6 years ago
Flags: approval?
Flags: approval4.4?
Flags: approval4.4+
Flags: approval+
Target Milestone: --- → Bugzilla 4.4
Thanks for the patch!

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunk
modified template/en/default/bug/edit.html.tmpl
Committed revision 8452.

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/4.4
modified template/en/default/bug/edit.html.tmpl
Committed revision 8438. 

dkl
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 832577

Updated

5 years ago
Blocks: 575211

Comment 11

5 years ago
There is a problem with the fix on checkin. When splitting the long line into several lines as described in comment 8,

  field = bug_fields.rep_platform

became

  field = bug_fields.
  rep_platform


I'm surprised that TT didn't complain. But I'm fixing this anyway to make the code clearer:

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/bug/edit.html.tmpl
Committed revision 8642.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified template/en/default/bug/edit.html.tmpl
Committed revision 8571.
You need to log in before you can comment on or make changes to this bug.