javascript errors not shown with symantec norton antivirus

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Peter Schaefer, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Firefox/1.1

The symantec NAV package comes with a popup blocker that redefines the windows
object. It seems javascript errors, like using nonexistant variables or
unterminated strings, do not show up anymore inside the are bracketed by the NAV
scripts. Actually I have no idea whether it is NAV or version 1.1, I'm just
naming suspects

Reproducible: Always

Steps to Reproduce:
1.write a javascript with an error inside a webpage
2.load page while the NAV popup blocker is running
3.look in console

Actual Results:  
No errors from the webpage.
I was using DTD HTML4.1 strict, if that makes a difference

Expected Results:  
give diagnostics for debugging

Comment 1

13 years ago
Seems more like a symantec bug than a Firefox one. Why not contact their
support? What is the link to the product so we don't have to go searching for
something that might be what you are using. 

Are you really using such an old version of Firefox? You should upgrade to 1.0.1
immediately. Why is your ua string below Firefox/0.10.1 on Win98 and your build
identifier Firefox 1.1 but this bug shows Windows XP?

What extensions do you have installed?

Can you give an example of a page where you think there is an error that is not
reported in the javascript console? Please include a link to a page which
illustrates the issue or attach the full page to this bug using "Create New
Attachment" link above.
(Reporter)

Comment 2

13 years ago
I am not using the same computer at work. 
I upgraded now to FF 1.0.1 rv: 1.7.6

I think I reproduced the problem, see: 
http://www.armyofanubis.net/hylZee/test.html

Basically, the symantec pop up blocker is a script inside 
<script language="javascript">
, while the script I am working on is inside
<script language="JavaScript" type="text/JavaScript">

errors in the second script don't show. maybe the error handlers can handle only
one type of script or so .. or maybe it is the DTD strict, which symantec
doesn't follow. Still the javascript is parsed, si it should throw errors

If I do the following in either head or body:
<script language="JavaScript" type="text/JavaScript">
<!--
alert('test');
var x =a;
var a=";
//-->
</script>

them at first it wont show errors about unterminated strings, then if one
comments out the string error, it shows the alert, but the warning about "a
unitialized" is missing ..

Here is the Symantec script, for completeness:
<script language="javascript">
<!--

function SymError()
{
return true;
}

window.onerror = SymError;

var SymRealWinOpen = window.open;

function SymWinOpen(url, name, attributes)
{
return (new Object());
}

window.open = SymWinOpen;

//-->
</script>

Comment 3

13 years ago
I have just stumbled into this.
See http://www.cs.ucl.ac.uk/staff/W.Langdon/javascript_hang.html
My example shows javascript sliently dying after a java script error.
The non-javascript HTML parts of the page are displayed ok.

Note this applies to Firefox and a very new build of deer park:
Deer Park 1.0+ alpha Gecko/2005/20050717 Firefox/1.0+
My PC is running WindowsNT 5.1 rv:1.8b4 Service pack 2
As far as I know, it is _not_ running symantec or any other popup blocker,
except the nice goodies that come by default in Firefox/DeerPark

Ok I should not write sloppy javascript code with bugs in it
but it is very helpful to get some sort of error reported rather than
everything stoping and the browser giving no clue as to what has happened.

Many thanks
Bill

ps my spam filter blocks *gmail*com*

Comment 4

13 years ago
(In reply to comment #3)

Error: nonexistant is not defined
Source File: http://www.cs.ucl.ac.uk/staff/W.Langdon/javascript_hang.html
Line: 27
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 5

13 years ago
More information. I _do_ get an error on the JavaScript Console
when I load http://www.cs.ucl.ac.uk/staff/W.Langdon/javascript_hang.html
if I do it from another PC!
May be all this should be under a new bug report?
Ok so what is different about this PC?
Number one it does not and never has had deer park on it.

Firefox 1.0.2 Mozilla 5.0 WindowsNT rv:1.7.6 gecko 20050321 firefox/1.0.2

The error on the JavaScript console is 
Error: nonexistant is not defined
Source File: http://www.cs.ucl.ac.uk/staff/W.Langdon/javascript_hang.html
Line: 27

BTW: when I switch between firefox and deerpark on the orginal PC (windowsNT
5.1) I get a box saying Firefox Update | Incompatible Components | The following
components are not compatible with the new version of firefox you have just
installed | show java console 0.1
Note this is the Java Console -- not the JavaScript Console. I have ignored this
message uptill now. From memory I do not think the "show _java_ console" option
appears on the deerpark tools menu.

Once again, Many thanks

Bill

Comment 6

13 years ago
(In reply to comment #5)

Sounds like a bug in the extension <http://showjavaconsole.mozdev.org/>. You can
check it out by either using safemode or by uninstalling the extension to see if
the JavaScript console works. You can configure the Java plugin to start the
console, so this extension really isn't needed imo.

mozdev appears to still be down due to the flood...

Comment 7

13 years ago
(In reply to comment #6)
> Sounds like a bug in the extension <http://showjavaconsole.mozdev.org/>. You can
> check it out by either using safemode or by uninstalling the extension to see if
> the JavaScript console works. You can configure the Java plugin to start the
> console, so this extension really isn't needed imo.

On the original PC; I have run both firefox and deerpark in safemode.
I have uninstalled java console extension (in firefox it was greyed out of the
tools| extensions menu, which held a message saying "java console 0.1 not
compatible with firefox 0.1.0.1" (?hmm not sure I remembered the last version
number correctly). None of these changes have made any difference to the bug.
I.e. the javascript console still refuses to log anything.

I have installed the latest build (gecko/20050712 firefox/1.0+) of deerpark
on a third PC. As far as I can tell it is ok, ie the bug is not seen. To try and
provoke the error I tried to "sanitize" deerpark and crashed windows. Deerpark
javascript console continued to work fine.

In the last few weeks I have installed deerpark twice. (I installed firefox
sometime near the end of last year). Deerpark has crashed the ialmrnt5 display
several times (I have not found a simple/repeatable example worth a bug report).

Once again many thanks for your help
Bill

Comment 8

13 years ago
(In reply to comment #7)
Just a quick update. I have uninstalled deerpark (including deleting files in
C:\Program Files\Deer Park Alpha 2\ and reinstalled it (build gecko/20050712).
I have deleted everything in C:/.../Local Settings/Temp and
C:/.../Local Settings/Termporary Internet Files.
I have uninstalled DeerPark (including delete) again and uninstalled Firefox
(including deleting files in C:/program files/Firefox...) and reinstalled
deerpark. I have rebooted several times. I have tried the new installation in
safemode. Always Deer Park refuses to talk to its javascript console.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712
Firefox/1.0+

Ps: Netscape 7.2 is still working ok:-)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804
Netscape/7.2 (ax)

As always any help is most welcome
Bill

Comment 9

13 years ago
(In reply to comment #8)
More by random chance than judgment, the problem with my PC's installation has been fixed. Please see bugzilla 314571.
Once again mnay thanks for all your help.
Bill
You need to log in before you can comment on or make changes to this bug.