If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

accessing index.cgi causes Template creation error with SELinux

RESOLVED DUPLICATE of bug 394986

Status

()

Bugzilla
Documentation
RESOLVED DUPLICATE of bug 394986
13 years ago
10 years ago

People

(Reporter: nick_abbo, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

I get this error when i try to access the bguzilla installation with SELinux:

Template creation failed: failed to create context: failed to create context: 
failed to load Template/Stash/XS.pm: Couldn't load Template::Stash::XS 2.14:

Can't load '/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-
multi/auto/Template/Stash/XS/XS.so' for module 
Template::Stash::XS: /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-
multi/auto/Template/Stash/XS/XS.so: failed to map segment from shared object: 
Permission denied at /usr/lib/perl5/5.8.5/i386-linux-thread-
multi/DynaLoader.pm line 230.
 at /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-
multi/Template/Stash/XS.pm line 27

BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.5/i386-linux-
thread-multi/Template/Stash/XS.pm line 27.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.5/i386-linux-
thread-multi/Template/Config.pm line 96.




Reproducible: Always



Expected Results:  
load up the defalt bugzilla install
This would be a tech support/documentation issue...

You need to add Bugzilla's data directory to the httpd context in SELinux.  I
forget the exact syntax for it, but I've seen it just recently in a couple
places.  I'll see if I can track it down.  It's a "chcon" command.
Assignee: general → documentation
Group: webtools-security
Status: UNCONFIRMED → NEW
Component: Bugzilla-General → Documentation
Ever confirmed: true
Here it is:

chcon -Rv -t httpd_sys_content_t /path/to/bugzilla/data/

Let me know if that works or not.  Want to make sure that's right before we add
it to the docs :)
wait, something about the error you're getting sounds strange to me.  It's
failing to load the shared library for the module, not failing to create files
in the template cache directory...

Are you sure SELinux is related?  That sounds like a normal permissions problem.
 Make sure your perl libraries are readable by the webserver user.

Comment 4

12 years ago
I've had the same problem on Fedora Core 3 - I've changed the permissions of 
my perl modules/libraries - but to no avail.

HELP!!

Comment 5

12 years ago
Can you disable SELinux to see if this is really a related issue or not?

If you're on Fedora, you can disable SELinux by editing /etc/sysconfig/selinux
with the following changes :

SELINUX=disabled

Reboot and test again.

Comment 6

12 years ago
I have found a posting on a newsgroup that suggested reinstalling the Template 
module and saying "no" to XS::Stash.

I did this and it worked... I might try your suggestion, but currently it 
works.

Cheers.
Another command that we discovered works on IRC today is:

chcon -R --reference=/var/www/html /path/to/bugzilla

This sets more than just the "type" context, it gets the user and mode parts as well.
See also bug 380077.
we had a number of bugs on this issue... consolidating them.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394986
You need to log in before you can comment on or make changes to this bug.