Unable to locate MSVCIRT.dll causes crash

VERIFIED DUPLICATE of bug 27601

Status

SeaMonkey
Build Config
P3
critical
VERIFIED DUPLICATE of bug 27601
18 years ago
13 years ago

People

(Reporter: Sitsofe Wheeler, Assigned: use leaf@mozilla.org)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
When trying to start up both the latest nightly (21/02) and M13 on one 
particular computer, I receive the following error message four times:

NSPR: EventReceiver: mozilla.exe - Unable to Locate DLL

Mozilla then tries to start but only a tiny window with just the gadgets 
appears. The window can be resized, but the display is not refreshed and 
nothing really appears inside. Mozilla has installed and run fine on other 
computers.

This computer has never seen a copy of Mozilla before so I doubt it is a 
settings problem.

Builds: M13 and 0221 WinNT 4 SP6
(Reporter)

Comment 1

18 years ago
Created attachment 5558 [details]
GIF screenshot of the error received
(Reporter)

Comment 2

18 years ago
Created attachment 5559 [details]
M13 Dr. Watson Crash log
(Reporter)

Comment 3

18 years ago
This bug may be related to one of the following:
bug 1457 - ss: Distribution is missing msvcirt.dll 
bug 6962 - msvcirt.dll not included in Milestone 5 release 
bug 19165 - [DOGFOOD][PP] Win32 - App won't start with old MSVCRT.DLL 
bug 24373 - msvcrt.dll, msvcirt.dll no longer required in product 

Comment 4

18 years ago
Windows.
Assignee: cls → leaf

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
This bug should be fixed now... can you verify?
(Reporter)

Comment 6

18 years ago
I still see this in a 17 March nightly build. Apologies for the delay...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

18 years ago
sean, do i need to include this dll? i thought the bug causing this crash was
fixed...

Comment 8

18 years ago
look like we might have regressed.  I'm not aware that we need MSVCRT.dll.  I'll 
see if I can track down what is requiring it this time.
MSVCRT we definitely need, used by XPCOM and just about everything else.

MSVCIRT appears to be used by three components: gkhtml.dll, gkparser.dll, 
xpacct32.dll

Comment 10

18 years ago
This is a dup of bug #27601, no?
(Reporter)

Comment 11

18 years ago
jrgm@netscape.com: I think you're right. The only difference is that I see this 
on WinNT. Marking as a duplicate.

*** This bug has been marked as a duplicate of 27601 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Adding crash keyword
Keywords: crash

Comment 13

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.