Tooltips under the yellow spots on the map on this page do not format correctly (they work fine in IE)

RESOLVED DUPLICATE of bug 67127

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 67127
13 years ago
13 years ago

People

(Reporter: Ron McMahon, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

The tooltips (AREA TITLE = HTML Tags) do not format in the same way that IE
does.  The TITLE= tag has the code   embedded in it (to force a linefeed)
but Firefox displays these characters as a block with no linefeeds.  Therefore
the display doesn't work.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://www.quickdrive.com/Borders/BorderCrossings.asp
2. Move your mouse over one of the yellow-backed dots on the page.
3. View the tooltip text box that appears, it won't be formatted with linefeeds.

Actual Results:  
Tooltip box is not formatted correctly.

Expected Results:  
It should insert line feeds between numerous rows under each area tag ToolTip
(TITLE HTML TAG) item.

The OSS road to nirvana is better than closed source!

Comment 1

13 years ago
-> Core - HTML: Parser
-> Trunk

This seems to be caused when Firefox interprets the line breaks in HTML CDATA as
actual line breaks.  Since title is of type Text (== CDATA), these line breaks
should be replaced with spaces.

http://www.w3.org/TR/html401/types.html#type-cdata

Depending on how common this construction is, this might be a candidate for the
compat keyword.
Component: General → HTML: Parser
Product: Firefox → Core
Version: unspecified → Trunk

Updated

13 years ago
Assignee: firefox → parser
QA Contact: general → mrbkap

Comment 2

13 years ago
Dup of bug 45375. The FF version is bug 218223

*** This bug has been marked as a duplicate of 218223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
also see: bug 47078, bug 67127

Comment 4

13 years ago
second thoughts.. sorry for the spam
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.