default browser menu doesn't include self

RESOLVED FIXED in Camino0.9

Status

defect
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: vlb, Assigned: jaas)

Tracking

unspecified
Camino0.9
PowerPC
macOS

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050322 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050322 Camino/0.8+

I downloaded the latest Camino Nightly Build yesyetrday (2005032208 (v0.8+)) and
noticed that the "Default Browser" menu in the Preferences doesn't list Camino. 

I would have expected it to list itself. :-)


Reproducible: Always
-> josh
Target Milestone: --- → Camino0.9
really this time.
Assignee: pinkerton → joshmoz
Assignee

Comment 3

14 years ago
This bug is documented in the default browser code - the problem is that Launch
Services says org.mozilla.navigator is a web browser, but when we ask Launch
Services to tell us where the application for that bundle ID is, it has no idea
even though its obviously a currently running application. Silliness. We'll have
to add some way to use the currently running copy of Camino if launch services
can't find one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
how common is this? i mean, doesn't it sorta make the entire feature useless?
I thought there was code to ensure that camino was always in the list?
Assignee

Comment 6

14 years ago
Camino is always in the browser list, but that doesn't mean Launch Services can
find it. Launch Services might not be finding any number of applications it
gives us, and sometimes that includes Camino (however stupid). So - if LS can
find Camino, this will work. If it can't, this won't. And yes - it makes the
feature useless when LS can't find Camino. So what I'm saying is we need to add
code to substitute the running Camino when LS can't find it.
Assignee

Comment 7

14 years ago
Posted patch fix v1.0Splinter Review
Attachment #178530 - Flags: superreview?(sfraser_bugs)
Comment on attachment 178530 [details] [diff] [review]
fix v1.0

Would be good to know why Launch Services is failing though. What error is
returned?
Attachment #178530 - Flags: superreview?(sfraser_bugs) → superreview+
Assignee

Comment 9

14 years ago
I can't repro right now, so I can't tell you. I assume it is failing because I
was shuffling around copies of Camino and it simply lost track of the app path.
Assignee

Updated

14 years ago
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Assignee

Comment 10

14 years ago
landed on trunk
You need to log in before you can comment on or make changes to this bug.