Closed Bug 287393 Opened 15 years ago Closed 15 years ago

The recurrences "Forever" radio button should be false by default, and only true when set by user or eventDialog.js

Categories

(Calendar :: Sunbird Only, defect)

x86
SunOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jt, Assigned: mostafah)

References

Details

Attachments

(2 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.7.6) Gecko/20050301 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.7.6) Gecko/20050301 Firefox/1.0.1

The recurrences "Forever" radio button should be false by default for the event
dialog. It should only be set true by the user, or eventDialog.js


Reproducible: Always

Steps to Reproduce:
1.Create an event that recurrs 2 times
2.Save it
3.Double-click to edit it


Actual Results:  
Both "Forever" and "Repeat number of times" radio buttons are enabled


Expected Results:  
Only "Repeat number of times" should be enabled and set to 2.
Attached patch Trivial fix for bug (obsolete) — Splinter Review
Just make the "Forever" radio button false by default.
Attachment #178374 - Flags: first-review?(pavlov)
Comment on attachment 178374 [details] [diff] [review]
Trivial fix for bug

why not just remove the 'selected' attribute?
actually, i think the radio should be set to something for new events and event
that don't have recurrence specified. Otherwise it might stay empty, which is an
error. (and radioboxes just always need to have exactly one item selected. one,
not zero)
Fix eventDialog.js to set at any one time only 1 radio button for recurrences
("Forever", "Number of Times", and "Until")
Attachment #178374 - Attachment is obsolete: true
Attachment #179162 - Flags: first-review?(pavlov)
Use JS to set 1 out of 3 radio buttons. Added new helper function for radio
groups,
radioGroupSelectItem() so that manipulating radio groups becomes easier as we
add more radio buttons to said group. Thanks to mvl for suggestions.
Attachment #179162 - Attachment is obsolete: true
Attachment #179587 - Flags: first-review?(pavlov)
Attachment #178374 - Flags: first-review?(pavlov)
Attachment #179162 - Flags: first-review?(pavlov)
I'm pretty sure this report is a duplicate of bug 268451.  Jeremy, I understand
if you want to keep this open because of your patch on it, but it might be
better to move things over to that bug.
No, just keep this one open. This one has way more information, like a patch
*** Bug 268451 has been marked as a duplicate of this bug. ***
Comment on attachment 179587 [details] [diff] [review]
Use JS to set the correct radio button. Add helper functions for radio groups

r=mvl
Attachment #179587 - Flags: first-review?(pavlov) → first-review+
Patch checked in (with some whitespace changes, to kill tabs)
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Re-opening bug.  I'm having serious problems with this patch in 1 Aug nightly.

When editting an event that has already been set to recur until a certain date I
get:
i is not defined
for applicationUtils, line 375.

The problem is worse though.  Fixing i to be item results in no item be selected
when a recuring event is editted.  If 'Until' isn't selected again, the onOK
will fail with the ever pleasant: "flushItem DB error: not an error"
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Attached patch clean up my messSplinter Review
Ehm, i messed up somewhat. I didn't check what the function returns. This patch
should fix it.
Attachment #191252 - Flags: first-review?(jminta)
Comment on attachment 191252 [details] [diff] [review]
clean up my mess

Much better.  Makes bug 302986 disappear too, for me.  I'll let myk confirm
though.
Attachment #191252 - Flags: first-review?(jminta) → first-review+
patch checked in
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
*** Bug 302986 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.