Image in web page not displaying

VERIFIED DUPLICATE of bug 29643

Status

()

Core
ImageLib
P3
major
VERIFIED DUPLICATE of bug 29643
19 years ago
19 years ago

People

(Reporter: James Everingham, Assigned: pnunn)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
This page shows a live image using animated .gif magic.  It work in 4.x and
doesn't display anything in mozilla.
(Assignee)

Comment 1

19 years ago
Hey. A steamer lane cam is _gonna work_ in mozilla.
I'll dig into it.
-P

Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 2

19 years ago
http://166.90.144.66/cgi-bin/nph-dtspush.cgi?camera=jpeg/surfline04/cam0.%%08ld.
rgb888.enc

and its a jpeg image.
(Assignee)

Comment 3

19 years ago
I'm not getting the data stream for some reason.
I get an image request, but the data isn't coming.
Judson, can you tell me whats happening when the uri 
request comes in?
-P

Comment 4

19 years ago
I think the image url is invalid. The %s are not allowed in urls and have to be
properly escaped. One special problem here maybe that %%08ld is only converted
to %25%08ld and not converted to %25%2508ld, because %08 is a valid escape
sequence. But if the url is 
http://166.90.144.66/cgi-bin/nph-dtspush.cgi?camera=jpeg/surfline04/cam0.%25%2508ld.rgb888.enc
is does also not work, not in mozilla and not in NC 4.61. This I do not
understand at all. 

Comment 5

19 years ago
The image also does not load if I switch off url escaping/unescaping. I think
there are at least two problems here, one deals with the wrong url and one with
the image load. This maybe the timing problem often seen with animated pictures

Comment 6

19 years ago
I think this is a dup of bug 17067.
(Assignee)

Comment 7

19 years ago
This bug could be related to #15625, #18330, #29643, #28747, and
#17067. I'll be testing some patches contributed in some of these
other bugs.
-P

Comment 8

19 years ago

*** This bug has been marked as a duplicate of 29643 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

19 years ago
Rubber-stamping as verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.