Closed Bug 287501 Opened 16 years ago Closed 15 years ago

cannot load certain site due to memory cache disabled

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 184304

People

(Reporter: e_chow, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

After disabling memory cache in about:config and restart Firefox, certain
website will refuse to load. Including

www.ebay.ca (www.ebay.com works fine)
www.altavista.com

and some more which I forget.

When you enter the URL of those site, or click any hyperlink that link to it,
the status bar will show "Waiting for www.ebay.ca" then it simply said "done"
without displaying the new page. Old page is still there and no eror message at all.

Reproducible: Always

Steps to Reproduce:
1.disable browser.cache.memory.enable in about:config
2.restart Firefox
3.Try www.ebay.ca or www.altavista.com

Actual Results:  
nothing is loaded. old page remain on the screen

Expected Results:  
should load the page correctly

Tested on plain Firefox 1.0.1 and 1.0.2 with no extention
If I set browser.memory.cache.enable=false, these websites fail to load. If I
set browser.memory.cache.enable=true and browser.memory.cache.capacity=1, then
these websites load correctly! So this bug has something to do with the memory
cache being on or off, regardless of the size of the memory cache.
This bug also affects www.zend.com and some sites that use php session cookies.
In a test site that did nothing special beyond use standard php sessions the
site failed to load. The bug might be related to the handling of session cookies.

This bug still exists as of Firefox version 1.0.4
This bug is clearly related to the http cache related headers and is easily
reproductible.

By default php session cookies are sent with a 'Pragma: no-cache' header.
If the firefox memory cache is disabled, the pages won't load, although the
browser shouldn't cache anything...

On the other hand, if one sets the php session_cache_limiter to 'private', thus
allowing the browser to cache the content, then the page will load.

But this bug IS related to the cache disk capacity since when set to 0, the
browser will load the page.
(In reply to comment #3)
> But this bug IS related to the cache disk capacity since when set to 0, the
> browser will load the page.

good point, JMC. The memory cache problem goes away if the disk cache is
disabled! Here are my test results:

- browser.cache.disk.capacity=0 and browser.cache.memory.capacity=0 --> ebay.ca
loads correctly
- browser.cache.disk.capacity=0 and browser.cache.memory.capacity=1 --> ebay.ca
loads correctly
- browser.cache.disk.capacity=1 and browser.cache.memory.capacity=1 --> ebay.ca
loads correctly
- browser.cache.disk.capacity=1 and browser.cache.memory.capacity=0 --> ebay.ca
fails to load!
I got the same problem with using 1.5 Beta 1, sites like www.klipfarm.com wont
load :(
Additional sites that don't load:

world.altavista.com
www.archive.org
www.linuxpackages.net
This bug don´t exist in versions 0.9.3 and 1.0 Preview Release. Since version
1.0 this bug exist.
Additional sites that don't load:

www.guiadohardware.net
www.radiouol.com.br
Flags: blocking-aviary2.0?
This is happening on the MacOSX platform as well -- ATM I'm using Camino as of
the past weekend's nightly builds, but I've seen this on Firefox & earlier
Mozilla as well -- this has been going on for over a year IIRC.

Another website that refuse to load in this manner:

www.versiontracker.com

Flags: blocking-aviary2.0? → blocking1.9a1?
Flags: blocking-aviary2?
this bug is a duplicate of bug 184304, please resolve.

*** This bug has been marked as a duplicate of 184304 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Flags: blocking1.9a1?
Flags: blocking-aviary2?
You need to log in before you can comment on or make changes to this bug.