Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 287740 - Expose advanced table semantics
: Expose advanced table semantics
: access, dev-doc-needed, sec508
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla11
Assigned To: alexander :surkov
: alexander :surkov
Depends on: 491851
Blocks: htmla11y tablea11y
  Show dependency treegraph
Reported: 2005-03-25 14:31 PST by Aaron Leventhal
Modified: 2011-11-28 07:47 PST (History)
5 users (show)
mzehe: in‑testsuite+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

patch (2.24 KB, patch)
2011-11-22 23:48 PST, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description Aaron Leventhal 2005-03-25 14:31:13 PST
Not sure what APIs we will use to expose this information, but we should make
use of axis, headers and scope attributes in tables, as well as the colgroup,
tbody, thead and tfoot tags when exposing our tables.
Comment 1 Aaron Leventhal 2005-09-27 11:55:36 PDT
This info is now available via ISimpleDOMNode.
Comment 2 Aaron Leventhal 2006-06-27 14:32:16 PDT
Does nsIAccessibleTable support make use of axis/scope/headers?
Comment 3 alexander :surkov 2009-05-13 05:56:08 PDT
bug 491851 adds support of scope and headers attributes.
Comment 4 alexander :surkov 2009-12-11 17:57:26 PST
We could expose axis attribute as an object attribute I think or as a description of the cell if it makes sense. No one accessible API seems to be adjusted for this. Probably we could suggest some changes to IA2 API because it seems axis attribute usage is all about making queries of cell data by the categories (see and
Comment 5 Marco Zehe (:MarcoZ) 2011-11-01 06:01:51 PDT
Alex, is this still valid? Or id you implement something during the accessible table refactor to account for this?
Comment 6 alexander :surkov 2011-11-01 06:19:22 PDT
(In reply to Marco Zehe (:MarcoZ) from comment #5)
> Alex, is this still valid? Or id you implement something during the
> accessible table refactor to account for this?

comment #4 seems to be still valid
Comment 7 alexander :surkov 2011-11-22 23:48:50 PST
Created attachment 576417 [details] [diff] [review]

expose axis as object attribute that's the best what we can do for now. I'll file a propose to IA2/ATK groups to extend existing interface to pick up axis capabilities.
Comment 8 Marco Zehe (:MarcoZ) 2011-11-23 00:14:09 PST
Comment on attachment 576417 [details] [diff] [review]

Comment 9 alexander :surkov 2011-11-24 03:33:49 PST
inbound land
Comment 10 Ed Morley [:emorley] 2011-11-24 08:14:40 PST
Comment 11 Marco Zehe (:MarcoZ) 2011-11-28 07:47:32 PST
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111127 Firefox/11.0a1

Note You need to log in before you can comment on or make changes to this bug.