Strange behaviour of the URL bar - added to

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: t8m, Assigned: travis)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When I jump to the site http://www.amdzone.com/ using the URL bar during
the loading of the page it suddenly changes the URL address in the
URL bar to http://www.amdzone.com/i/pcstats_2.gif.

Reproducible: Always

Comment 1

19 years ago
Tested with the 2000-02-22-08-M14 nightly binary on WinNT, the URLbar displays 
http://www.amdzone.com/ and no other URL during and after the page load.

t8m@centrum.cz, what was the build ID for the Mozilla you were using?
(Reporter)

Comment 2

19 years ago
Still the same behaviour in the latest Linux build - 2000022217.
I'm using access through proxy and relatively slow line 5-10 KBytes/s so it
could be caused by any of these things.

Comment 3

19 years ago
I see the buggy behavior.  I load the page by pasting the url into the address
field and hitting enter.  The page load finished (the banner ad seems to be the
last thing to load) and then the extended URL,
http://www.amdzone.com/i/pc_stats_2.gif, pops up in the address field.
I'm using 022208 build on NT wiht a high speed LAN connection.

Comment 4

19 years ago
Confirmed with 2000-02-22-16-M14 on WinNT. This site is in the midst of a domain 
address transfer that has obviously not propagated everywhere yet.

pcstats_2.gif is referenced nowhere in the code I got for http://www.amdzone.com
but does appear in the code retreived from http://63.210.10.37/ - updating URL.
The text in the new site is mostly black-on-white; on the old it is mostly
white-on-black. The HTML code looks pretty sane for something MS-generated.

The URLbar updates to show http://63.210.10.37/i/pcstats_2.gif while the page 
is still loading.

Who wants to guess at a component for this one?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Strange behaviour of the URL bar → Strange behaviour of the URL bar - added to
(Reporter)

Comment 5

19 years ago
Changing OS to All
OS: Linux → All

Comment 6

19 years ago
seeing this on this url: http://wwww.aint-it-cool-news.com

it becomes /images/190/120x90.button.gif


Comment 7

19 years ago
we should move this to a component soon...
(Reporter)

Comment 8

19 years ago
It seems that this bad behaviour stopped in the Linux build 2000031909 or in
some build before this one. So I'm marking it as WORKSFORME. Could someone
verify it on other OSes.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

19 years ago
Hmmmm... sorry for that, but it still changes the URL bar on some conditions,
but it's less frequent that it was before the 2000031909 build.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

19 years ago
-> Networking.
Assignee: cbegle → gagan
Status: REOPENED → NEW
Component: Browser-General → Networking
QA Contact: asadotzler → tever

Updated

19 years ago
Target Milestone: --- → M16

Comment 11

19 years ago
->travis
Assignee: gagan → travis
(Assignee)

Comment 12

19 years ago
Try this with the latest builds from after I checked in the new session history 
and loading.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

18 years ago
I've forgot to verify this bug. And yes, it's fine after the new session history.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.