print preview causes menu bars to disappear

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: uberbubba, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

File->Print Preview

All the menu components disappear -- "File Edit Menu ...", Nav bar, bookmarks
bar.  The only thing left at the top is the tab bar.  Bottom of the screen is
still OK -- Mozilla, Mail, Composer, Address Book buttons still work.  Hitting
Ctrl-N or using the Mozilla button on the bottom cause new, correctly operating
window to appear.

Inside Print Preview, the "Close preview" button and all the margin handling
widgets are also missing.  Existing tabs are still active, but the new tab
button is dead.  The only way to dismiss the preview is to close the window or
tab (Delete Tab widget works).

Browse history was inaccessible.

Reproducible: Always

Steps to Reproduce:
1. Left mouse File pulldown.  
2. Select Print Preview


Actual Results:  
For technical details, see above.  

From a user experience point of view, I wanted to print a page while filling out
a rebate form.  I could not get back to the form I was filling in and had to
start over.

Expected Results:  
It should have left the menu bar unchanged.  Or...

It should have shown the Print Preview controls.



Modern theme.  Windows XP, SP1.

Comment 1

14 years ago
WORKSFORME
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050217

Reporter, can you provide a publicly accessable URL where you get this problem?

Comment 2

14 years ago
I have experienced something similar today with FireFox 1.0.2 where the print
preview toolbar stuck at the top of the page and the standard menu bar and
toolbar not reappearing after the print preview "Close" button is clicked.

The bug I found is repeatable but with more steps than required by the original
poster.  These steps were executed under Windows; I haven't tried them yet under
Linux or any other OSes.

The steps are:
1) Select File->Print Preview
2) Click the "Print..." button on the Print Preview toolbar to open the print
dialog.
3) Close the print dialog with OK, Cancel, or the window's 'X' button
4) Find a file and tell Windows Explorer to open it with FireFox.  (I
demonstrated with an HTML file and alternately with a JPG file.  I'm not sure if
there are exceptions.
5) Switch back to the FireFox window with Print Preview open and observe that
the document has changed to the file you opened.
6) Click the print preview "Close" button and observe that the print preview
toolbar remains and the standard menus and toolbar do not reappear.  If you had
multiple tabs open, the tab bar should have reappeared.

I have only demonstrated this with FireFox, not the Mozilla suite, and it does
not exactly duplicate the description of the original bug.  Should I open a
separate bug for this?
(Reporter)

Comment 3

14 years ago
I'm sorry, I can't.  It was the rebate confirmation page from Staples's "Easy
Rebate" system.

Here is a partial URL:

https://www.stapleseasyrebates.com/staples/ ......

Oddly enough, last night I fully exited Mozilla twice then re-invoked it with
the same results on any URL.  I have since rebooted my machine and it no longer
occurs at all.  Anywhere.  I have tried to provoke it tonight, but it's hiding now.

FWIW, I was running IE and TurboTax at the time.  I visited the Intuit site once
or twice.  I also use the jTFlashManager tool to control Macromedia Flash.

Comment 4

14 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050521
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.