Mozilla is ignoring stylesheets after 1st time for non-port 80 requests

VERIFIED DUPLICATE of bug 29370

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 29370
20 years ago
15 years ago

People

(Reporter: rrothenberg, Assigned: cbegle)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Testing Mozilla Build 2000022108 on a non-port 80 site (ie, http://machine:81)

and finding that the stylesheet (http://machine:81/default.css) is ignored

after the first time it is loaded. Checking the web server logs, there are 304's

returned so it is requesting the pages. But they stylesheets are not being

applied.
I have the same problem with Build 2000030214, Linux i386

Reloading the page causes the page to render without the stylesheet.  Maybe 1
out of 5 times reloading the stylesheet will be applied.  My httpd logs also
show sucessful 304's when requesting the stylesheet.

I'll attach sample HTML and CSS.
I should have added that I get this error on my Apache server running on port
80.  Also, the stylesheet is applied every time when reloading the page by
hitting enter in the location bar.

Anyhow, I just validated the CSS stylesheet I attached (I should have done this
initially).  There is an error in the BODY selector.  The 'font' property is
missing a size, which is required.  Correct the property and the stylesheet is
applied for every reload:

body {
    font: 1em serif;
    background: white;
    color: black;
}

This is still a bug.  Mozilla should have ignored the 'font' property and
continued parsing the stylesheet.
Sorry for the barage of posts...I should go to bed before I make any more
mistakes...anyhow, I wrote:

> This is still a bug.  Mozilla should have ignored the 'font' property and
> continued parsing the stylesheet.

This is confusing, given the example CSS I give right before it.  When I wrote
"...should have ignored the 'font' property...", I'm referring to the 'font'
property as it appears in the invalid CSS stylesheet, not as it appears in the
example of the correction.
sounds like bug 29370, css apearing on and off.

marking dupe


*** This bug has been marked as a duplicate of 29370 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified as a dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.