Uninstall 1.0.1 after update to 1.0.2 can't uninstall 1.0.2 or reinstall

VERIFIED DUPLICATE of bug 247884

Status

()

Firefox
Installer
--
major
VERIFIED DUPLICATE of bug 247884
13 years ago
12 years ago

People

(Reporter: Andrew, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 1.0.2

I downloaded the upgrade from 1.0.1 to 1.0.2 when I went into the Add/Remove 
programs section of Windows XP I saw that both versions where displaying. I 
then uninstalled 1.0.1.   1.0.2 still shows in the programs installed, but the 
shortcuts and the file directory are no longer showing. I then downloaded 
1.0.2 fully and tried to install it. It gave me an error message 
saying "unspecified error" and gave the option of "OK"

I then tried to uninstall 1.0.2 but it gave the following error

0: Uninstall log folder not found:

HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla Firefox\1.0.2(en-US)\Uninstall Log 
Folder

OK


I can not install or uninstall 1.0.2

Reproducible: Always

Steps to Reproduce:
1.See Summary
2.
3.

Actual Results:  
See Summary

Expected Results:  
1.0.1 should have uninstalled and 1.0.2 should have installed sole so that no 
Registry values would be missing

I don't have anything else to report that will help with this. I do have a 
screen shot of the second error message though.
(Reporter)

Comment 1

13 years ago
Created attachment 178911 [details]
.doc Contains a screen shot and brief description of problem

Comment 2

13 years ago
The root cause here is bug 247884, so duping against that one. When you
uninstalled 1.0.1 you really uninstalled 1.0.2 because of this bug.

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

13 years ago
This doesn't solve the issue of not being able to install Firefox, as of this 
point Firefox cannot be installed. Firefox is not able to be used at all, 
ever. I'd like to be able to use it, but short of a clean install, I cannot 
use Firefox.

Comment 4

13 years ago
This is a symptom of bug 247884. To install Firefox, download the installer from
mozilla.org and run it.

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.