Closed Bug 28816 Opened 21 years ago Closed 21 years ago

Selection problems (dragging and dbl-click) with punctuation (<, >, /, etc.)

Categories

(Core :: DOM: Selection, defect, P3)

DEC
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 12460

People

(Reporter: jpranevich, Assigned: mjudge)

References

()

Details

When looking at a page with HTML-like punctuation (a source window, for
example), the user is unable to properly select text OR text is properly
selected by the selection hilite does not cover some punctuation. As
cut-and-paste are not working for me in this build, I am unable to determine
whether the problem is cosmetic however I am able to repsoduct it every time.

On a line like this:

<a href=http://foo.com/test.html>Test URL</a>

If you double-click the "http", you get a selection from the href= through to
the space at the end of the word "Test" However, the = and the > will not be
hilited in that example.  The expected result is that both of these should be
hilited leaving an unbroken hilited block.

It is arguable that we're hiliting too much anyway on a double-click. This bug
does not address that problem. That's bug #6875

Please note that this problem also occurs when you use a click-n-drag to hilite
text.

I have not verified that this bug happens on pages other than the view source
page as it can be difficult to find pages that contain HTML. I am assuming that
the view-source page uses the standard display engine although double-checking
this would be a good idea.
m16
Target Milestone: M16
(Please note bug #12460.)
view source is a generated page


*** This bug has been marked as a duplicate of 12460 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Verifying as duplicate; left note in 12460 to request verification of dupes when
that bug is verified.

This works for me within Composer using this morning's Mac OS build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.