onChange not firing for select boxes when key based selection is made

RESOLVED DUPLICATE of bug 126379

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 126379
12 years ago
12 years ago

People

(Reporter: Timothy C. Quinn, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

When a drop down (select) is changed by pressing keys - Arrow or alpha, the
onChange event is not firing.

Since the key presses are *changing* the selected item, the onChange should
fire. For now, I have to workaround by handling a keydown event for mozilla only
which is kind of sloppy code.

BTW - I tested in Mozilla 1.8a6 and the same problem was there.

Reproducible: Always

Steps to Reproduce:
1. Create a drop down
2. Create a onchange event for drop down
3. Set focus to drop down and press up down arrow keys or alpha keys to select items

Actual Results:  
onChange does not fire with key presses that result in change in selected item.

Expected Results:  
onChange should fire when a keypress changes the selected item.
(Reporter)

Comment 1

12 years ago
Created attachment 178958 [details]
Simple testcase for bug

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.