If-Modified-Since header not sent for livemarks at startup

RESOLVED DUPLICATE of bug 274382

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 274382
13 years ago
12 years ago

People

(Reporter: Philip Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

When starting Firefox, a request is made to retrieve the feed for each livemark.
This request is sent without an If-Modified-Since HTTP header, causing the full
feed to be retrieved.

Not sending an If-Modified-Since header causes extra load on servers as feeds
are retrieved each time a user starts Firefox. Some sites will ban clients
automatically if too many requests are sent
(http://slashdot.org/faq/accounts.shtml#ac1050).

It also means more bandwidth is consumed on the client than is absolutely
necessary (a particular problem for dial-up users - see bug 287341).

Reproducible: Always

Steps to Reproduce:
1. Add a livemark.
2. Close down all Firefox windows.
3. Open Firefox with a packet sniffer running in the background.
Actual Results:  
A request is made for each feed with no If-Modified-Since header.

Expected Results:  
The last modified date of each feed should be stored. This date should be sent
in an If-Modified-Since header so that only feeds that have changed are downloaded.

Better still, it would be good if Firefox could only make requests for feeds
that are due a refresh anyway (i.e. making sure sites are only polled at their
update frequency).
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 274382 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.