HTML page not displayed correctly

RESOLVED DUPLICATE of bug 63895

Status

()

RESOLVED DUPLICATE of bug 63895
14 years ago
13 years ago

People

(Reporter: dagobart, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050330
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050330

In the page http://home.tiscali.ch/mynewsgroup/gd.html the display is not
correct. The text should be displayed under the title bar - but it is mixed with
the title bar. The page was made from ClickToConvert 5.5. Other browser (IE and
Opera) are displaying the page correctly.

Reproducible: Always

Steps to Reproduce:
1.View http://home.tiscali.ch/mynewsgroup/gd.html
2.See the page: Text mixed with title bar
3.

Comment 1

14 years ago
Created attachment 179156 [details]
Test case

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

I enclose a simplified testcase which still shows the problem. Note that 
it seems to need both tables, though I suspect that it might be possible
to simplify further.

This is probably a True Bill.

Updated

14 years ago
Keywords: testcase

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → Trunk
(Reporter)

Comment 2

14 years ago
I forgot to add the note the this problem exists also with Mozilla Browser.

Comment 3

14 years ago
looks like bug 63895?
(Reporter)

Comment 4

14 years ago
Yes could be the same as https://bugzilla.mozilla.org/show_bug.cgi?id=63895

But then I don't understand why this very old bug is still there and not fixed
yet...

Comment 5

14 years ago
(In reply to comment #4)
> But then I don't understand why this very old bug is still there and not fixed
> yet...

Bug 63895 Comment 25

It would need someone learn the understand the layout code well enough to modify
the behaviour of Absolute Containing Blocks without damaging anything else. 
Alternatively a fix for this may fall out of any reorganisation/simplification
of the layout code.

You are probably right if you think that your problem has been ignored for
4 years or so, but unless you know of resources that can be brought to bear
on either of strategies suggested, there is not a lot that you (or I can do).

There is a work-around in Bug 63895 Comment 1 and Bug 63895 Comment 21 .
Depends on: 63895
(Reporter)

Comment 6

13 years ago
This bug and the depends bug https://bugzilla.mozilla.org/show_bug.cgi?id=63895
still not fixed.

Comment 7

13 years ago
This page doesn't validate at validator.w3.org and is therefore not vaild HTML
4.01 Transitional. There are 11 errors, including table related errors. Is this
not just a poorly written webpage?

http://validator.w3.org/check?uri=http%3A%2F%2Fhome.tiscali.ch%2Fmynewsgroup%2Fgd.html
(Reporter)

Comment 8

13 years ago
This bug #288351 depends on #63895. There the validator doesn't find important
problems related to the Firefox bug: It's about absolute and relative
positioning of tables (not missing of doctype lines). THIS bug must be fixed.
(Reporter)

Comment 9

13 years ago
Again - I checked the 11 errors from the validator. They have absolutly nothing
to to with the Firebox bug about absolute and relative positioning of tables. 

Well - it's quite nice this validator - but it doesn't help here. See bug #63895.

Comment 10

13 years ago
(In reply to comment #7)
> This page doesn't validate at validator.w3.org and is therefore not vaild HTML
> 4.01 Transitional. There are 11 errors, including table related errors. ... 

Richard, Although attempting an SGML parse of a web page can be good way
of checking bugs and developing useful test cases, the existence of 
HTML errors is of almost no evidential value, because if a layout defect
exists in a faulty web page, there is probably at least one correct
web page which also shows it.

>Is this not just a poorly written webpage?

No. Very definitely not.

I would guess that my comment 5 still applies in full measure, and I am only
writing here to deprecate trying to use a validator to close or head off
bug reports.

This report will probably be fixed by a fix for bug 63895 and if there is such
a resolution it is SINE DIE - deferred to a future when there are layout 
resources available to apply to it.
(Reporter)

Comment 11

13 years ago
Reply to comment #10:

Thanks Ben for your clarification - and I hope that one day this bug will be
fixed...
Note that the original page has been changed so that the bug report is invalid,
since the STYLE attribute on the table that makes it relatively positioned has
been removed.

In any case,

*** This bug has been marked as a duplicate of 63895 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 63895
Resolution: --- → DUPLICATE
And PLEASE do not have conversations like the above conversation on the other
bug; lots of noise makes the bug harder to understand and less likely to be fixed.
You need to log in before you can comment on or make changes to this bug.