Closed Bug 28852 Opened 22 years ago Closed 22 years ago

Key combo to turn ON/OFF Japanese IME incorrectly activates "File" menu

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: momoi, Assigned: mjudge)

References

Details

(Keywords: inputmethod, platform-parity, Whiteboard: [PDT+] w/b minus on 3/7)

** Observed with 2/22/2000 Win32 Build **

(Maybe there is already a duplicate of this problem somewhere ...)

I have been noticing this problem lately in Mail Composer and it is a very annoying and 
serious problem. This is probably restricted to only Windows where "ALT + ` " key combo
is used to turn ON/OFF Japanese input mode with Japanese IME.

1. Open a Composer window. At this point, Japanese input mode should be OFF.
2. When the window opens, turn ON the JPN IME by pressing ALT + ` keys together. While doing
   this, pay particular attention to the "File" menu.
3. Note that while doing step 2, "File" changes color indicating that the menu is activated.
4. Now input some Japanese characters, commit them to the Ediot field and then press Enter to
   insert a line break. This is when "File" menu opens.

Notes:

A. This problem happens every time, you change the input mode using "ALT + `".
B. Actually the problem is worse when you switch from Japanese to ASCII input mode. In that mode, if you 
    press any of the keys matching an accesskey for the menus, they open up.

This really hampers Japanese input in Mail Composition and should be fixed ASAP.
Assigning myself as QA contact as it affects mail composition
in Japanese  critically. Nominating for Beta 1.
Keywords: beta1
QA Contact: sujay → momoi
reassign to hyatt since he knows about the menu activation stuff and that is
what is interfering with IME.
Assignee: brade → hyatt
I think hyatt is working on some other ALT related bugs.
Can you use a menu command to work around this keystroke problem?
My guess is that a huge percentage of Japanese Windows users will 
use ALT + ` method, I would say more than 95%. You can use the task bar
keyboard icon to turn the Japanese IME ON and OFF but this slows
down inputting too much. We should not try to challenge the 
expected usage behavior of the majority of Japanese Windows users.
The key combo works for all other other applications
including our own 4.x, and this doesn't make for good impressions
in Japan.
Status: NEW → ASSIGNED
Target Milestone: M15
Let me add that it's similar to English keyboard users 
seeing some menu opening every time they use Shift key to 
type uppercase letters and then seeing some other menu
open when they let that Shift key go. 
I can't imagine any Japanese users wanting to do that kind 
of task via a keyboard menu choice on the task bar.
This is to make a point that this bug is a serious impediment to
everyday use of Japanese input and we should not let Beta out to
Japan with this problem in it.
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
removing myself from Cc: list...
Target Milestone: M15 → M14
Mike Judge has graciously agreed to investigate this.  If it gets too hairy, 
Mike, feel free to send it back.
Assignee: hyatt → mjudge
Status: ASSIGNED → NEW
fixed as of today
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
** Checked with 2-28-2000 Win32 build. **

It's not fixed yet. I see the same behavior as before.
When I engage ALT + ` to turn on the JPN IME, the "File" menu
gets highlighted, Then if I do something like hitting the
Enter key, the File menu opens. 

Normally you press 1) the ALT key, then 2) the "`" key while holding the ALT
key, and then 3) let go of the "`" key, and finally 4) let go of the 
ALT key. It's at step 4, the highlight occurs on File menu.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: pp
THIS time i made sure the fix went in sorry.
Status: REOPENED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
** Checked with 3/2/2000 Win32 build **

This is not quite fixed. The "File" menu still gets activated under
a fairly common condition. Let me explain.

1. When you use ALT + ` keys to turn ON and OFF the JIME,
   a normal assumption, if you're very "careful", is that 
   after the state in which the "ALT + `" keys are pressed 
   together, the user will let go the "`" key first, and then 
   the "ALT" key. This is how the ON and OFF should work under
   a very careful condition.

   Under this ideal condition, your fix works. 

2. But human beings are not perfect, when you are typing fast 
   or moderatey fast in Japanese, which a lot of users do,
   you might let the ALT key go just a "fraction of a second"
   earlier than the the "`" key.
   All JPN applications I have used before allow for this slight
   miscue in letting go the ALT key first. 

   Mozilla currently does not and shifts the focus to the "File"
   menu. This happens whether you're turning ON the IME or OFF.

   This miscue is such a common occurrence so that any JPN IME 
   application needs to build in some allowance for it. Without
   putting in this tolerance, this fix cannot be considered complete.

Re-opening ...
   
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Needless to say, Comm 4.7x allows for such a miscue. 
However, i would argue against this remaining problem being PDT+.  Removing PDT+ 
designation for re-evaluation.
Whiteboard: [PDT+] → [PDT]
This beta is supposed to go to Japan. No application I know of

meant for Japanese causes this problem -- it is part of the

fix requested as PDT+ for Beta. This approach to parcel out

portions of the fix for this or that designation is not acceptable

for this bug.

As I stated before, say, you are using a keyboard in a normal way

as normal users would typing English and if suddenly a menu

opened up, wouldn't you fix that becaue that would really hamper

the use of Mail Compose or Composer in a normal way? 

Now if I'm a normal user of Japanese IME, I'm going to run into

this remaining problem pretty much without fail. 

Why do you want to subject normal users to that? I certainly cannot 

agree with this kind of suggestion which does not take into

account what is involved in inputting Japanese.



Fixing remaining part of the problem is part of the original

request. Don't parcel it out just for your convenience.

I disagree with hyatt completely on this.
I repeat. This problem is not fixed. Please fix it!
Do you want users in Japan to try out our Mail and adopt it as
a regular mail agent to use, or use our Composer to compose
HTML pahes on a reagular basis.  Then, fix this bug. 
I just dicovered that there is complete data loss when this miscue
happens. I turn on JIME with this slight understandable miscue.
I can type in Japanese line, and then I'm ready to commit,
so press the Enter key, the File menu opens, so dismiss by
pressing the Enter key, and then commit by Enter key.
At this point, the whole entry I just entered disappears!

There is NO way we can have this defect in the product for
Japanese editing. Who wants to put up with the data loss
you just spent time inputting. I won't use a Mail
or Composer with this defect in it.
i will investigate this one sec. the only way to fix this is for the ime 
composition listener to "know" to turn off the alt is down only flag.  currently 
we have no way to do this. i think ftang should look at this now. this is out of 
the scope of simple event handling miscues.  The event system is trying as best 
it can to understand what is happening but there is no way for it to know that 
the "`" key was pressed!  Only my knowing that IME was "turned on" can we fix 
this. I will look into this but I will require some help.

Note: this is getting more complicated than the 1 line change we had before. 
this MAY not be taken for beta but we can hope.
Status: REOPENED → ASSIGNED
If it just sent the ' key down message to me,  I'd be able to clear my flag.  I 
don't understand why it doesn't send me that.
Regarding my remark about the data loss above, what happens is
that a new Composer window opens and so it looks like the
input has disappeared. The window behind that new window still
contains the comitted input. I would like to correct thatm but
this behavior is confusing.
[PDT+] w/b minus on 3/7
Whiteboard: [PDT] → [PDT+] w/b minus on 3/7
Maybe this could be patched in the Windows widget code, mike.  We could send a 
fake ALT key up or something.
Hi, mjudge and others, wasn't this fixed on 3/4? 
If so, please mark it resolved/fixed.
mike checked this fix in last week
Status: ASSIGNED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
** Checked with 3/6/2000 Win32 build **

Yes, the remaining problem is now fixed with the above
build. I don't see the "File" menu open even I when I
miscue and let go of the ALT key a fraction of a second before
the grave "`" key.
Thanks, mjudge, hyatt, and ftang!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.