need a startup screen when firefox is started..

VERIFIED DUPLICATE of bug 198605

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 198605
13 years ago
13 years ago

People

(Reporter: Raghavendra H I, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Friends,

I enjoyed using Fire fox for surfing the Net. But u can make it better by
including the following facilities.

1. Firefox needs (more) time to load on older systems compared to IE. But once
it is loaded it is unbeatable. I use Firefox in my Computer Education Institute
for Internet Training to my students with AMD 500 Mhz systems. The problem here
is, when a student double clicks Firefox Icon, he will not know that It is
already being loaded. Hence Again he double cliks the icon, to load a second
instance of Firefox which increases the time needed to load. Some times they
keep on clicking Firefox icon until they see around 10 to 12 instances(windows)
of Firefox poping up simoltaniously on the screen. This problem can be solved by
displaying a Flash screen(Which displays firefox logo and a loading message),
immediately after the first time he double cliks the firefox icon. It is very
help ful for people like me, who use older systems. [May be you can give an
option to disable it on Faster Systems.]

2. Some times Firefox crashes due to various reasons ( IE is NOT an exception ).
If the crash happens when we are using several windows for surfing
simoltainiously, the user will not know where he was, when firefox crashed. I
request you to add a feature which automatically stores the current url
locations of all firefox windows into a text file on desktop on firefox crash,
which can be used by user to directly move to previous url location without
delay. This will be a great help for every one. 

hope my suggestions will be considered for inclusion.

thank you 

Raghavendra. H. I.
STAR Computers.
Sagar. Karnataka. India.




Reproducible: Always

Updated

13 years ago
Assignee: nobody → firefox
Component: Build Config → General
QA Contact: build-config → general

Comment 1

13 years ago
You may find that you are asked to ensure one bug/request only per report in
Bugzilla.

Comment 2

13 years ago
I think suggestion 1 is not wanted by the Firefox developers, see bug 198605
comment 11 and bug 198605 comment 12. 

Suggestion 2 is already requested in bug 19454, bug 36810 and other bugs, maybe
you could try something like the SessionSaver extension from update.mozilla.org,
see
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=1.0&os=Windows&category=Tabbed%20Browsing&numpg=10&id=436.

Comment 3

13 years ago
One issue per bug please. The 2 issues you mentioned have already been reported.
Marking this one as a duplicate of the first issue.

*** This bug has been marked as a duplicate of 198605 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.