Closed Bug 288767 Opened 15 years ago Closed 15 years ago

[RSS] Bad rendering for DTD specifications

Categories

(Core :: DOM: HTML Parser, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 22942

People

(Reporter: support, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050319
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050319

Following recomandations of W3C for official rss 1.0, the rendering of this code
isn't correct for the 6th line:
<?xml version="1.0"?>
<!DOCTYPE rdf:RDF [
<!ENTITY % HTMLlat1 PUBLIC
 "-//W3C//ENTITIES Latin 1 for XHTML//EN"
 "http://www.w3.org/TR/xhtml1/DTD/xhtml-lat1.ent">
%HTMLlat1;
]>

In IE browser it well rendering.

Reproducible: Always

Steps to Reproduce:
1. Just open my example link: http://bepolytech.be/news.rdf
Actual Results:  
Browser shows:
%HTMLlat1; ]> 
which is wrong.

Expected Results:  
Browser should not show %HTMLlat1; ]>

None
A validating parser is required to load external entities. Mozilla does not have
a validating parser unfortunately. Dupe of bug 22942 

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Summary: [RSS] Bad rendering for DTD spécifications → [RSS] Bad rendering for DTD spécifications
Summary: [RSS] Bad rendering for DTD spécifications → [RSS] Bad rendering for DTD specifications
also note that you sent that thing as text/html, not as text/xml...
You need to log in before you can comment on or make changes to this bug.