JS Debugger Service is not installed

RESOLVED INVALID

Status

Other Applications
Venkman JS Debugger
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Marc d'Entremont, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2

The debugger still opens but it pops up a dialog. The message is:
An exception occurred while initializing, please file a bug.
BadMojo 4: JS Debugger Service is not installed. @
<chrome://venkman/content/venkman-debugger.js> line 122 (initDebugger)

Reproducible: Always

Steps to Reproduce:
1.go to tool in the menu and choose Javascript debugger
2.
3.

Actual Results:  
Alert dialog
Debugger opens

Expected Results:  
Debugger opens

Comment 1

13 years ago
I had the same problem. After the popup message, the Javascript Debugger opens
but doesn't work.
I'm using Firefox 1.0.2, Windodw XP and Javascript Debugger 0.9.84
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317
Firefox/1.0.2
JS Debugger version 0.9.85

Have you tried with the latest version of the debugger? (0.9.85, as far as I'm
aware)
(Available from http://hacksrus.com/~ginda/venkman/)

Also, could you check about:buildconfig and see if --disable-jsd is specified?

Comment 3

13 years ago
I'm trying to run Venkman 0.9.84 on Firefox 1.0.4 in Fedora Core 3.  Everything
installs just fine, but when I try to run it, I receive the following error
"BadMojo 4: JS Debugger Service is not installed. @
<chrome://venkman/content/venkman-debugger.js> line 122 (initDebugger)"

Tried removing and reinstalling, but have the exact same error.
(In reply to comment #3)
> I'm trying to run Venkman 0.9.84 on Firefox 1.0.4 in Fedora Core 3.  Everything
> installs just fine, but when I try to run it, I receive the following error
> "BadMojo 4: JS Debugger Service is not installed. @
> <chrome://venkman/content/venkman-debugger.js> line 122 (initDebugger)"
> 
> Tried removing and reinstalling, but have the exact same error.

Reading comments is helpful sometimes. Have you checked whether 0.9.85 works? If
so, this bug can be closed unless someone can reproduce the problem in the
latest build (0.9.85).

Thanks.

Comment 5

13 years ago
That would be because JSD is not installed. Obviously. JSD has to be built with
the core, it cannot be installed later. Load "about:buildconfig", look for
--disable-jsd, and then go whine at your distro if you're using their version. :P

Comment 6

13 years ago
(In reply to comment #5)
> That would be because JSD is not installed. Obviously. JSD has to be built with
> the core, it cannot be installed later. Load "about:buildconfig", look for
> --disable-jsd, and then go whine at your distro if you're using their version. :P

Sorry.  I'm a bit unclear.  I think what you are saying is that I do not want
--disable-jsd, is that correct?

I installed 0.9.85 from the xpi.  My configure arguments include --disable-jsd
--enable-extensions=default,-venkman,gnomevfs,irc,-xmlterm,-sql and I have the
same problem.

Comment 7

13 years ago
That is exactly correct. As configure's help states, --disable-jsd "[disables
the] JavaScript debug library", which is what Venkman uses.

Comment 8

13 years ago
(In reply to comment #7)

Using a build without -disable-jsd (in gentoo emerging with 
export USE="mozdevelop jsd") eliminated the problem.

Comment 9

12 years ago
I had this same issue, and it looks to be that firefox was compiled with --disable-jsd.  Can I make a suggestion that this be fixed by improving the dialogue that appears to read something like:

"One cause of this may be that your browser was compiled with the --disable-jsd flag set.  This plugin requires that the JS Debugger Service be enabled.  Either recompile it yourself without the --disable-jsd flag, or complain to your distribution to not use that flag."

Right now, the message is fairly perplexing.

Comment 10

12 years ago
I second comment #9, please prodce a better MSG.

Comment 11

12 years ago
This is an enviromental configure problem (i.e. user error). Bug 328750 changed the message to be more explanitory about what's wrong when JSD is missing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.