Wrong CSS selector wins

VERIFIED DUPLICATE of bug 24031

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 24031
19 years ago
19 years ago

People

(Reporter: Braden, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Mozilla renders the second instance of "red in amaya" in blue. Amaya is right.

The rulesets that affect this element are

  BLOCKQUOTE BLOCKQUOTE BLOCKQUOTE { color: blue }
  DIV > BLOCKQUOTE BLOCKQUOTE { color: red }

Both of these selectors have a specificity of '030'. So, the last one declared
wins--the text should be red.
(Assignee)

Comment 1

19 years ago


*** This bug has been marked as a duplicate of 24031 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

19 years ago
Oops, sorry for the dupe.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

19 years ago
Created attachment 7203 [details]
testcase from levien.com
You need to log in before you can comment on or make changes to this bug.