Closed Bug 289389 Opened 15 years ago Closed 15 years ago

Cannot interpret backslash

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: stuart.rainsford, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

I wrote a page with the following line of code:
<form method="post" action="\members.php" onSubmit="return validateForm(this)">

As you can see, I have used a backslash instead of a forwardslash.
IE interprets this and changes it to a fowardslash and loads the required page.
Firefox does not do this, and instead returns the following error:
"The requested URL /\members.php was not found on this server."

Reproducible: Always
>IE interprets this and changes it to a fowardslash and loads the required page.
That is a "bug" in IEbecause this violates the RFCs. 
You can only use a slash as path seperator and in general you have to escape a
backslash 

-> invalid (no bug)
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.