Closed Bug 289502 Opened 18 years ago Closed 12 years ago

When I load atrios.blogspot.com, it appears briefly, then some ad text replaces it

Categories

(Core :: DOM: HTML Parser, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: derek, Unassigned)

References

()

Details

(Keywords: qawanted)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

I think atrios.blogspot.com changed someinternal code, because the problem also
appears in Mozilla & Firefox for Win, and Mozilla for Linux.

Reproducible: Always

Steps to Reproduce:
1. Go to http://atrios.blogspot.com
2. Wait for the page to finish loading.
3.

Actual Results:  
The proper page flashes briefly, then disappears, and is replaced by some text
that was in the original page but is only ads in one of the columns.

Expected Results:  
Loaded the page.

Like I mentioned, it seems to be a common problem with several different Mozilla
based platforms now.
WFM Mozilla 1.8b on WinXP.

Which version of Mozilla did you try?
(In reply to comment #1)
> WFM Mozilla 1.8b on WinXP.
> 
> Which version of Mozilla did you try?

I just tried it with Mozilla 1.7.6
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050319
on WinXP, and it exhibited the problem. 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050408
Firefox/1.0+
The URL works for me.
Derek, can you please try a firefox nightly (1.1beta) build, and report if you
still see this problem?
http://ftp.uni-erlangen.de/pub/mozilla.org/firefox/nightly/latest-trunk/
I see the same. Not every time though, often it works and then reload brings
back the symptoms. Pressing <esc> at just the right moment is an (inconvenient)
workaround. Btw; I'm on linux; so not just Windows.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050406 Firefox/1.0.2
(Debian package 1.0.2-3)
Attached file Minimal test case
I created a minimal test case (not valid HTML, but loadable) which shows the
symptoms. Removing any more, putting in TD tags, or even moving the page text
outside the table makes the page load as expected (ie. show "some text", and
not keep spinner spinning).
Comment on attachment 181716 [details]
Minimal test case

><HTML><HEAD><LINK rel="stylesheet" type="text/css" href="http://proxy.blogads.com/busjptdpndbtuofu/1112109971946/ba_as.css"/></HEAD><BODY>Some text here
> 
> <TABLE>
><TBODY><TR>
> <SCRIPT src="http://proxy.blogads.com/busjptdpndbtuofu/1112109971946/feed.js" language="javascript"/>
></TR>
></TBODY></TABLE></BODY></HTML>
Attached file Corrected
I am sorry, I messed up that last one when I tried to edit the attachment
(there was a wrong url in there, so it didn't work). So let my try again.
One further comment and then to bed: The referenced stylesheet can be empty, and
the javascript can be just "document.write('a');".

Actually it can be "document.write('');" but that makes FF lose keyboard focus
which is very annoying (is that a different bug?).
>>Core
>>All
Component: General → JavaScript Engine
OS: Windows XP → All
Product: Firefox → Core
Version: unspecified → Trunk
1)  document.write isn't JS engine.  It's DOM.
2)  Please reassign bugs when changing component!
3)  This isn't an issue on trunk, and it's not a security issue, so why are we
    keeping this bug on life support?

Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
On deer park alpha 2 (debian), I can reproduce this bug reliably with the test
case that is attached.

Note that it is not reproducible at atrios.blogspot.com anymore, due to changes
there.

I don't know how to reopen bug, the radio button disappeared when I logged in.
Nevermind.
I'll re-open it. Anyone else able to help out?
Status: RESOLVED → UNCONFIRMED
Keywords: qawanted
Resolution: WORKSFORME → ---
See comment 10 items 1 and 2, please.

At a guess, we're somehow managing to trigger onload before we actually execute
the document.write.  Also at a guess, fixing bug 84582 will fix this bug.
Assignee: firefox → parser
Component: JavaScript Engine → HTML: Parser
Depends on: 84582
QA Contact: general → mrbkap
So...  I can't tell what the expected behavior with the testcases is, so I can't tell whether I'm seeing the bug, or whether it's fixed....
Assignee: parser → nobody
QA Contact: mrbkap → parser
The test case is not self-contained. It relies on a script on an external server and the script is gone.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago12 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.