Last Comment Bug 289714 - Loaded-as-data XML documents should not generate <parsererror>
: Loaded-as-data XML documents should not generate <parsererror>
Status: RESOLVED FIXED
: dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: XML (show other bugs)
: Trunk
: x86 Linux
: P3 normal with 2 votes (vote)
: mozilla51
Assigned To: Thomas Wisniewski
:
: Andrew Overholt [:overholt]
Mentors:
: 313854 837463 (view as bug list)
Depends on: 45566 251354 399502
Blocks: 313854
  Show dependency treegraph
 
Reported: 2005-04-09 11:17 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2016-11-07 19:18 PST (History)
32 users (show)
reed: wanted1.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
DOMParser throws (37.45 KB, patch)
2007-10-17 07:38 PDT, Olli Pettay [:smaug]
Ms2ger: review-
Details | Diff | Splinter Review
289714-trigger-detailed-onerror-on-failed-xml-xhrs-instead-of-adding-a-parsererror-node.diff (30.64 KB, patch)
2016-06-02 22:05 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs.diff (13.60 KB, patch)
2016-06-04 14:59 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
918703-make-console-xml-parsing-notices-more-informative.diff (2.79 KB, patch)
2016-06-04 17:21 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-fix-gmp-test.diff (1.95 KB, patch)
2016-06-16 20:28 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-fix-xpcshell-tests.diff (4.91 KB, patch)
2016-06-16 20:31 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs.diff (20.80 KB, patch)
2016-06-30 21:05 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-make-console-xml-parsing-notices-more-informative.diff (2.79 KB, patch)
2016-06-30 21:08 PDT, Thomas Wisniewski
jst: review+
Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs.diff (20.84 KB, patch)
2016-07-16 19:29 PDT, Thomas Wisniewski
jst: review+
james: review+
Details | Diff | Splinter Review
289714-OLD-make-console-xml-parsing-notices-more-informative.diff (2.79 KB, patch)
2016-07-20 11:47 PDT, Thomas Wisniewski
jst: review+
Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs.diff (19.95 KB, patch)
2016-07-20 11:53 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs.diff (27.14 KB, patch)
2016-07-27 16:04 PDT, Thomas Wisniewski
bzbarsky: review-
Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff (20.93 KB, patch)
2016-08-01 16:47 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff (30.35 KB, patch)
2016-08-14 22:39 PDT, Thomas Wisniewski
wmccloskey: review-
Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff (24.79 KB, patch)
2016-08-17 10:02 PDT, Thomas Wisniewski
wmccloskey: review+
Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff (25.20 KB, patch)
2016-08-22 17:53 PDT, Thomas Wisniewski
bzbarsky: review+
Details | Diff | Splinter Review
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff (25.38 KB, patch)
2016-08-29 19:36 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review
289714-make-console-xml-parsing-notices-more-informative.diff (2.80 KB, patch)
2016-08-29 19:38 PDT, Thomas Wisniewski
no flags Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2005-04-09 11:17:25 PDT
When we have a well-formedness error in an XML doc loaded as data, should we
really generate a <parseerror> node?  Or should we just clear out the DOM and
return?  It seems like the latter would be a better idea; the question is
whether people out in the wild seriously depend on the former behavior...

Thoughts?  I think this should be pretty easy to fix if we decide to do it (esp.
once bug 251354 is fixed).
Comment 1 Jonas Sicking (:sicking) No longer reading bugmail consistently 2005-04-09 12:30:07 PDT
I do actually think people depend on the current behaviour. But I also think
it'd be ok to break them as long as we provided some other mechanism for
detecting the parse error. For synconous loads like xmlhttprequest (and doc.load
once we do that) we should IMHO throw an exception.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2005-04-09 12:37:44 PDT
Sync document.load() returns a boolean to indicate success or failure; it can
return false (as it does now) on parse error.

For xmlhttprequest, don't we already have a way to report errors?  We should use
it if we do.

I agree that we should have a way to indicate whether the document was parsed
correctly, though.  Maybe even add a boolean property on some document interface?
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2005-04-09 12:54:32 PDT
I think that if all the methods of loading indicate failure somehow, then it's
enough to just empty the document on failure since a successful load can never
result in an empty document. Though of course an additional flag wouldn't hurt,
but it might get tricky to figure out when to clear that flag...
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2005-04-09 13:06:14 PDT
OK, makes sense.  Will look into doing this, then.
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2005-04-09 13:51:34 PDT
Oh, and of course, we should check how IE deals with errors.
Comment 6 Bob Clary [:bc:] 2005-04-09 13:54:06 PDT
I don't think XMLHttpRequest has any method other than the <parseerror> element
to report the actual error. If you are going to do something else, why not
standardize on what MS does:
<http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xmlsdk/html/xmproparseerror.asp>
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2005-04-09 14:00:55 PDT
> I don't think XMLHttpRequest has any method other than the <parseerror> element
> to report the actual error.

It has an onerror handler, looks like.  Not completely trivial to use from C++,
but really easy from JS.

> why not standardize on what MS does

It's a thought.  Unfortunately, it's not very clearly documented.  For example,
the errorCode property is undocumented.  Do we need compat in errorCode values
if we implement this?  The filepos property doesn't say what it means by
"absolute file position" (is that bytes?  Or what?).  
Comment 8 Bob Clary [:bc:] 2005-04-09 15:04:39 PDT
(In reply to comment #7)

> It has an onerror handler, looks like.  Not completely trivial to use from C++,
> but really easy from JS.

True, but what error information do you get? 

> It's a thought.  Unfortunately, it's not very clearly documented.  For example,
> the errorCode property is undocumented.  Do we need compat in errorCode values
> if we implement this?  

I wouldn't think so, but you can start with 
1)
<http://msdn.microsoft.com/library/default.asp?url=/library/en-us/xmlsdk/html/PushModelParser_ErrorCodes.asp>
2)
<http://msdn.microsoft.com/library/default.asp?url=/library/en-us/wcexmldm/html/cerefIXMLParseErrorErrorMessages.asp>

1) is deprecated and 2) is supposedly CE .Net 4.2, but they share values and I
expect are standardized across MSXML implementations.

I would think that we would not have to be identical to their errorCode, nor in
their reason so long as we agreed that non-zero errorCode was an error.

The filepos property doesn't say what it means by
> "absolute file position" (is that bytes?  Or what?).  

If you are really interested, I can experiment and try to find out.

Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2005-04-10 08:38:59 PDT
> True, but what error information do you get? 

Not much, really.  Just that there was an error.  Just like the return value
from document.load.

> If you are really interested, I can experiment and try to find out.

If people don't rely on it, I'm not that interested... if they do, I sort of am.
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2007-02-04 14:40:55 PST
I think we should make this change, and make it as early as we can.

So the things we currently load as data are:  XMLHttpRequest, DOMParser, anything loaded by the syncload service, XMLDocument.load, and some xforms and xslt stuff.

I think we should treat these as following:

  XMLHttpRequest:  Null responseXML (already happens if the response is not XML)
                   and dispatch an error event.  For sync, throw.
  DOMParser:  Throw.
  Async XMLDocument.load: error event
  syncload service: throw
  XForms: ???
  XSLT:  ???

We seem to already have some code in our tree that assumes it should look for a parsererror tag.  We'll have to fix that, of course.

I do think we should do this asap so sites that depend on this have time to get fixed.
Comment 11 Jonas Sicking (:sicking) No longer reading bugmail consistently 2007-03-02 17:13:05 PST
This is really annoying, there's no reason we should keep doing this for yet another release.
Comment 12 Peter Van der Beken [:peterv] 2007-06-20 11:15:26 PDT
Pushing.
Comment 13 Olli Pettay [:smaug] 2007-09-27 06:13:14 PDT
Let's see if I manage to do this for M9. I should.
Comment 14 Olli Pettay [:smaug] 2007-10-02 09:03:12 PDT
Safari has also some kind of error document, which for example DOMParser
returns. Opera throws LSException "PARSE_ERR".
Neither of those, nor IE, seem to use onerror of XHR to indicate error in parsing.
Comment 15 Olli Pettay [:smaug] 2007-10-08 06:04:18 PDT
So I'm not so sure how important this is or what should be done in each case.
Comment 16 Boris Zbarsky [:bz] (still a bit busy) 2007-10-08 07:26:41 PDT
With XHR you could just set the document to null, I guess.
Comment 17 Jesse Ruderman 2007-10-10 19:51:30 PDT
I'll have to make changes to https://www.squarefree.com/userscripts/valid-xhtml.user.js (assuming this fixes bug 45566), but I'm fine with that.
Comment 18 Olli Pettay [:smaug] 2007-10-15 09:50:10 PDT
Bug 399502 should be fixed first to get events from xmldoc.load()
Comment 19 Olli Pettay [:smaug] 2007-10-17 07:32:47 PDT
As far as I see, XSLT generates the error page only if the page is loaded
to be visible (not as data). Document loading should be cleaned up a bit, but
for 1.9 XSLT behaves well enough, IMO.
So:
  XMLHttpRequest:  Null responseXML
  DOMParser:  Throw LSException like Opera
  Async XMLDocument.load: error event
  syncload service: throw
  XForms: Handles internally, report error to console as done already now.
  XSLT: when used in scripts, do whatever documented in nsIXSLTProcessor.idl
        (throw nsIXSLTException)

DOMParser could also just return null document?
Comment 20 Olli Pettay [:smaug] 2007-10-17 07:38:10 PDT
Created attachment 285230 [details] [diff] [review]
DOMParser throws

Peter, any comments?
Comment 21 Jesse Ruderman 2007-10-17 10:24:11 PDT
Please include information about the XML parsing error in the exception: line number, column number, reason.  https://www.squarefree.com/userscripts/valid-xhtml.user.js needs that information.
Comment 22 Olli Pettay [:smaug] 2007-10-17 10:46:43 PDT
Ah, true, that would be useful.
Comment 23 Olli Pettay [:smaug] 2007-10-17 12:11:54 PDT
Though, I don't know how to do it, or can't find any reasonable way to do it.
Comment 24 Damon Sicore (:damons) 2007-10-17 13:53:32 PDT
We've shipped this forever, right?  Why should this block beta?
Comment 25 Jonas Sicking (:sicking) No longer reading bugmail consistently 2007-10-17 13:57:30 PDT
Yeah, this should not block beta. I'd even say it shouldn't even block the release at this point, but since there is a patch we might as well drive it in.
Comment 26 Damon Sicore (:damons) 2007-10-17 14:09:53 PDT
I'm minusing.  That doesn't mean it won't go in, but we need to prioritize accordingly.  Anyone who objects can renom.
Comment 27 Boris Zbarsky [:bz] (still a bit busy) 2007-10-17 14:58:26 PDT
I thought the idea was that this is a pretty major change in behavior so we should get it shipped in beta so that web sites can adjust to it as needed.  That's if we're doing it for 1.9, of course.

Put another way, I would argue that if this doesn't make beta we shouldn't take it for 1.9.
Comment 28 Jonas Sicking (:sicking) No longer reading bugmail consistently 2007-10-17 15:08:39 PDT
I don't think this is a big enough change that if it doesn't make first beta we can't include it later. Most sites probably has no error handling at all so they assume that the XML is wellformed, and likely only ever gets that.
Comment 29 Olli Pettay [:smaug] 2007-10-17 23:54:14 PDT
(In reply to comment #21)
> Please include information about the XML parsing error in the exception: line
> number, column number, reason. 

The exception should contain also the JS line number etc where
for example parseFromString is called. Should the stack (nsIException.location)
contain the information about xml parsing error or perhaps inner exception
(nsIException.inner)? Suggestions?
Comment 30 :Ms2ger (⌚ UTC+1/+2) 2012-02-12 06:43:15 PST
Comment on attachment 285230 [details] [diff] [review]
DOMParser throws

We can't throw for DOMParser parsing errors.
Comment 31 Robert Longson 2013-02-03 02:39:00 PST
*** Bug 837463 has been marked as a duplicate of this bug. ***
Comment 32 Brian Bi 2013-02-03 10:09:35 PST
What's the status of this now? I filed 837463 and it got marked as a duplicate of this, but there hasn't been any activity here for nearly a year.
Comment 33 Thomas Wisniewski 2016-06-02 22:05:28 PDT
Created attachment 8759512 [details] [diff] [review]
289714-trigger-detailed-onerror-on-failed-xml-xhrs-instead-of-adding-a-parsererror-node.diff

I decided to try my hand at unraveling this again, based on the comments in this bug. To summarize, this patch triggers onerror instead of onload for an XHR that tries and fails to parse its response as XML. The onerror ProgressEvent is also given a sub-object (tentatively named relatedError) with the related parsing failure's info (message, source, source line, and line/column number). This seems to be in-line with what the comments in this bug were aiming at.

However, there are some web platform test issues that I believe need clarification. Firstly, if the XML response body is an empty string, the second test in XMLHttpRequest/responsexml-basic.htm expects the responseXML to be nulled out and for onload to be triggered. This patch would trigger onerror with a "no element found" relatedError, so I added a check to allow 0-length XML responses to be treated as this test currently requires. I'm not sure if the test should be changed instead, though.

There is also DOMParser-parseFromString-xml.html, which actually expects <parsererror> nodes for DOMParser() failures. This runs counter to what the XMLHttpRequest web platform tests expect. However, I'm again not sure if it would be best to change the tests, and have DOMParser() throw exceptions with relatedErrors (or something along those lines). As such I opted to just honor the current tests and have DOMParser() continue to add <parsererror> nodes. This of course makes the patch a bit more complex; a new SetDocumentFlags() call is used by XHRs specifically to tell the XML content sink not to add a <parsererror> node to the resulting document. DOMParser() of course doesn't make this call.

There are also a couple of web platform tests (and one mochitest) that were timing out, simply because they're sending text/plain responses without setting their Content-Type header to reflect that. As such, the XHR expected XML content, failed to parse it, and onerror was triggered by this patch. The tests didn't even think to check for an onerror case, and so they sat there until they timed out. I altered the relevant tests so they return the correct content type, and to also check for and treat onerror as a failure, so they wouldn't have to time out.

Finally, there is XMLHttpRequest/responsetext-decoding.htm. With this patch, four of its tests time out similarly, but it seems like they may intend to treat the content-type as XML. The problem is that their responses are only a BOM or a BOM followed by another BOM, which this patch treats as a non-0-length case for onerror. However, the tests don't seem like they should care whether onload or onerror are fired, as long as the responseText is set appropriately, and so I've simply altered them to pass in either case. I'm not at all sure if that's correct, though.

As for my patch itself, I opted to save the nsIScriptError from the XML content sink on the related nsIDocument during parse-time, then save it on the XMLHttpRequest for future use during the onerror code (since the pointed to the nsIDocument can be nulled before then). I'm not sure if that's the most graceful or appropriate approach, as I'm still new to the codebase.

As mentioned before, I also added SetDocumentLoadFlags() to handle the DOMParser()/XMLHttpRequest divide, since this seemed like the easiest and most obvious way to handle that case. I'm not sure if another similar mechanism would be more appropriate, though.

I'm also not sure if adding a new WebIDL type for ParseErrors is the way to go, but it seemed to be the path of least complexity, so I thought I'd start with that.
Comment 34 Hallvord R. M. Steen [:hallvors] 2016-06-03 13:19:47 PDT
Per the XMLHttpRequest spec:

https://xhr.spec.whatwg.org/#document-response
"let document be a document that represents the result of running the XML parser with XML scripting support disabled on received bytes. If that fails (unsupported character encoding, namespace well-formedness error, etc.), then return null."

So no XML parsing failures will (per spec) cause XHR error events, as far as I can tell.

IMHO it would be nice to align DOMParser and not create those parsererrror elements - but my opinion shouldn't count for much here, I'll rather ask Boris to chime in on this.

Triggering XHR.onerror for responses sent without content-type (and assumed to be XML): no, please. This is not likely to be web compatible.

Maybe silly question: why do we make an effort to make error details available to JS at all? Can't we just report the details in a console error message and be done? Perhaps exposing those details made sense in 2005, but the web has moved on and XML is much less important. JS-implemented XML error handlers is probably a very rare beast..
Comment 35 Thomas Wisniewski 2016-06-03 13:30:44 PDT
Sure, if all that's desired is to null out the document before onload, then this patch would certainly become much simpler.

You could be right the exposing the error in a more fine-grained manner may no longer matter much, since I basing that off comment #21 (from 2007). I was concerned because while the console does show a terse error message indicating there was a parsing failure, it doesn't give you specifics (which XHR had the parse failure, what the source was, etc). Perhaps that should be extended instead?
Comment 36 Hallvord R. M. Steen [:hallvors] 2016-06-03 13:59:55 PDT
I think reporting more info in the console would be great.
(Right now we often output utterly confusing and maddening "No element found" error messages with no context. There are plenty of questions on Stackoverflow regarding what this error means, improving it would be terrific).

annevk mentioned on IRC that the parsererror element thing is actually added to the DOM parsing standard now - I think it's a wart, but it was considered necessary for web compat so..
https://w3c.github.io/DOM-Parsing/#the-domparser-interface
Comment 37 Thomas Wisniewski 2016-06-04 14:59:42 PDT
Created attachment 8760015 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

Alright, here's a much simpler version of the patch which simply nulls out responseXML upon parsing failures, rather than doing anything with onerror. I'll see if I can find a way to improve the console messages, but I'm not sure what would be best. Perhaps even just prefixing them with "Error parsing XML: " would be a good start?
Comment 38 Hallvord R. M. Steen [:hallvors] 2016-06-04 15:23:38 PDT
"Error parsing XML: no element found" would be a great improvement, especially if it's also clearly associated with a URL. I'd suggest changing the wording slightly and say "no root element found".

Also, is un-labelled XML a thing? Do other browsers assume XML if a site sends XML without sending a content-type? Perhaps assuming text/plain would work better :)
Comment 39 Thomas Wisniewski 2016-06-04 17:21:46 PDT
Created attachment 8760023 [details] [diff] [review]
918703-make-console-xml-parsing-notices-more-informative.diff

True, browsers don't assume XML in that case, as Chrome and Firefox currently return response==responseText and responseXML=null for unspecified content-type responses. My earlier patch was just flawed and I didn't realize it at the time. The new patch doesn't have that kind of issue, thankfully.

As for changing the console error, this patch seems to do the job. The messages now have this format:
  XML Parsing Error: no root element found
  Location: http://w3c-test.org/XMLHttpRequest/resources/status.py?type=application/xml&content=
  Line Number 1, Column 1:

Of course the line/column number info is superfluous, given that it's repeated in the little link to the far right of such messages, but I'd rather re-use this format string since it's already in the localization file.
Comment 40 Boris Zbarsky [:bz] (still a bit busy) 2016-06-06 12:59:34 PDT
> I'll rather ask Boris to chime in on this

I don't know that I have any new opinions on this since my last comments in the bug, modulo checking what other browsers do and hence what web compat is likely to require.

> why do we make an effort to make error details available to JS at all

You mean why is there a <parseerror> thing in general?  Because that XML parser behavior was designed around an XML parser parsing content in a browsing context (i.e. yellow screen of death) and the idea was to show the user something at least moderately more useful than just a blank page, I think....  The side-effects on XHR and whatnot were not intended, but the parser behavior predated those things existing, so...

> Also, is un-labelled XML a thing? 

In general (i.e. not just over HTTP), sure.  Happens all the time for local files, right?  ;)

If you create a file with no extension containing this text and fetch it via XHR to a file:// URI, what should happen and why?  What should happen if its extension is .docx?

<?xml version="1.0"?>
<root>aaa</root>

and then try to fetch it via XHR
Comment 41 Thomas Wisniewski 2016-06-16 20:28:22 PDT
Created attachment 8763159 [details] [diff] [review]
289714-fix-gmp-test.diff

A try run uncovered two bugs: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f83f3523f74a

This patch fixes the first, where GMP has an "empty" XML document that's not really an XML document at all (no root element). Looking at the test, it's fine to just add an empty root element, since it's currently passing because there's a parsererror that it's ignoring.
Comment 42 Thomas Wisniewski 2016-06-16 20:31:27 PDT
Created attachment 8763160 [details] [diff] [review]
289714-fix-xpcshell-tests.diff

This patch fixes the other related failures in the above try run, where XPC shell tests are reading a non-XML file to test overriding the mime type, which of course fails because now the responseXML is null. As such I change the test to read an actual XML file and make sure it's still overriding the mime type as expected.

A new try run shows that there are only failures that seem completely unrelated to me (running them locally gives different results, which are the same results that I get without this patchset applied): https://treeherder.mozilla.org/#/jobs?repo=try&revision=dab588e6c61e
Comment 43 Thomas Wisniewski 2016-06-18 10:11:38 PDT
Alright, I've requested review for the non-test-change patches, as I think this is about where it needs to be.
Comment 44 Thomas Wisniewski 2016-06-30 21:05:47 PDT
Created attachment 8767029 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

I've rebased the patches, and folded the test-related ones into the main one where they ultimately belong.

Looks like a try run for all of them passes, aside from an unrelated intermittent and some other odd "pulse_actions" task I don't recall scheduling myself, which seems to have stalled: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e64abece97eb

Also note that two other bugs should be fixed by these changes as well: bug 521301 (related) and bug 313854 (a dupe, as far as I can tell).
Comment 45 Thomas Wisniewski 2016-06-30 21:08:44 PDT
Created attachment 8767030 [details] [diff] [review]
289714-make-console-xml-parsing-notices-more-informative.diff

And here's the rebased version of the additional patch to make the console errors a bit nicer.
Comment 46 Thomas Wisniewski 2016-07-16 19:29:20 PDT
Created attachment 8771722 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

Rebased.
Comment 47 Johnny Stenback (:jst, jst@mozilla.com) 2016-07-20 10:37:20 PDT
Comment on attachment 8771722 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

This looks good to me, though someone, maybe James Graham, should sign off on the web-platform test changes as I don't know the intricacies of the files involved in that. And someone who works on toolkit (Justin Dolske?) needs to review the toolkit changes. A few minor nits below.

+XMLDocument::SetDocumentLoadFlags(int32_t flags) {
+  mLoadFlags = flags;
+}
+
+int32_t
+XMLDocument::GetDocumentLoadFlags() {

Function opening brace on its own line in this file please.

- In nsExpatDriver::HandleError():

   if (serr) {
-    rv = serr->InitWithWindowID(description,
+		rv = serr->InitWithWindowID(description,

This looks like a spurious white space change.
Comment 48 Johnny Stenback (:jst, jst@mozilla.com) 2016-07-20 10:39:30 PDT
Comment on attachment 8771722 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

Dolske, can you have a look at the toolkit changes here? Or find someone else if there's a better candidate.
Comment 49 James Graham [:jgraham] 2016-07-20 10:48:56 PDT
Comment on attachment 8771722 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

Review of attachment 8771722 [details] [diff] [review]:
-----------------------------------------------------------------

wpt changes look fine to me.
Comment 50 Thomas Wisniewski 2016-07-20 11:47:54 PDT
Created attachment 8772957 [details] [diff] [review]
289714-OLD-make-console-xml-parsing-notices-more-informative.diff

(In reply to Johnny Stenback  (:jst, jst@mozilla.com) from comment #47)
> Comment on attachment 8771722 [details] [diff] [review]
> This looks like a spurious white space change.

You're right, it seems like I uploaded a strange version of that patch. That line was meant to be changing "description" to "errorText" (to yield more error info). Here's a correct version of the patch (the other patch seems fine).
Comment 51 Thomas Wisniewski 2016-07-20 11:53:37 PDT
Created attachment 8772960 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

Ah, it turns out that this patch did indeed have a spurious change in the same place. Here's a fresh version with your comments addressed and that spurious change removed, carrying over existing r+'es.
Comment 52 Justin Dolske [:Dolske] 2016-07-21 17:21:50 PDT
Comment on attachment 8772960 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

Review of attachment 8772960 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not the right reviewer for the bulk of this patch, JST reviewed the other part, so flag him for this one too? (bz would be the other obvious choice)

But looking at the /toolkit part, I'm a little confused what this change is doing; it sounds like it you're making malformed XML call onerror instead, but then why the onload changes?

Also:

http://searchfox.org/mozilla-central/rev/6bb28c9903fe38d445cd2d3b17af4eabdade9335/toolkit/mozapps/extensions/content/extensions.xml#1461
http://searchfox.org/mozilla-central/rev/6bb28c9903fe38d445cd2d3b17af4eabdade9335/toolkit/mozapps/extensions/nsBlocklistService.js#654

AIUI this (XMLURI_PARSE_ERROR check) can never happen now?
Comment 53 Thomas Wisniewski 2016-07-24 16:58:22 PDT
No, ultimately I'm not calling onerror, since as per comment 34 it was considered a no-go due to compatibility concerns. As such I'm just nulling out the document to match the current spec. That's why those test changes are necessary.

And yes, it seems like XMLURI_PARSE_ERROR stuff needs to be changed to do a null-check as well. Thanks for mentioning that! I'll do another check for references like that I may have missed and update the patch before requesting JST review this.
Comment 54 Thomas Wisniewski 2016-07-27 16:04:53 PDT
Created attachment 8775352 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

As jst asked dolske to find another reviewer and he suggested you, it looks I'm back in your review queue, bz :)

Here's a fresh version of the patch where I've rechecked the codebase to see if I missed any XHR checks for parsererror/XMLURI_PARSE_ERROR as dolske suggested.

A try run seems fine, just stuff that appears unrelated: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fe9aa9542945

To sum up the patch, it changes XHRs to return null instead of a document with a <parsererror> root, if parsing fails. It does not onerror or throw, it just returns null. It only affects XHRs, not DOMParser/etc.
Comment 55 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 10:29:45 PDT
Have we checked what other browsers do here?

Do you know why there's still a test failure in XMLHttpRequest/responsexml-basic.htm ?
Comment 56 Thomas Wisniewski 2016-07-28 10:52:04 PDT
>Have we checked what other browsers do here?

I haven't tested it beyond Firefox and Chrome in the last couple of years, no (back then Firefox was the only one giving parsererror documents for XHRs).

Chrome currently returns a null document instead of a parsererror, so I doubt other browsers have changed, but if you'd like to be more through I'll try to find out ASAP.

>Do you know why there's still a test failure in XMLHttpRequest/responsexml-basic.htm ?

It seems to be failing because getElementById("n2") is returning a node, despite that node being set to a weird namespace. The test is otherwise passing fine.
Comment 57 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 11:15:44 PDT
> if you'd like to be more through I'll try to find out ASAP

That would be much appreciated.

> despite that node being set to a weird namespace

Oh.  That's a bug in the test.  id is a global attribute on all elements, regardless of namespace, nowadays.
Comment 58 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 12:21:59 PDT
Comment on attachment 8775352 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs.diff

>+++ b/browser/base/content/test/general/browser_bug409481.js
>-  ok(root.nodeName != "parsererror", "Sidebar is well formed");

What does this have to do with XMLHttpRequest?  That is, why is this change needed?

>+  ok(sidebar, "Sidebar is well formed");

No, just claiming that there is an element with this id in the document says nothing about what's inside it, which is what the old test tested.

>+++ b/dom/base/nsIDocument.h
>+  virtual void SetDocumentLoadFlags(int32_t flags) {}

This is probably more generic than it needs to be.  How about just an mSuppressParseErrorElement boolean and SuppressParseErrorElement()/SetSuppressParseErrorElement functions?

Needs documentation too.  Including why, for example, this is not the state for all data documents (e.g. because DOMParser _does_ want parseerror).

>+++ b/dom/xhr/XMLHttpRequestMainThread.cpp
>-  if (mResponseCharset != mResponseXML->GetDocumentCharacterSet()) {

No, this is wrong.  Consider the case when we start getting data and start parsing a document.  Partway through that, the page gets responseText.  We need to use the document encoding to generate that, no?  In the new setup this won't work right.  r- for this part.

This should be testable; if we don't have a test testing it already, please add one.

Of course you're right that you have to do this again in OnStopRequest before we drop our mResponseXML reference in the error case.  So some of this logic might need to be factored out into a helper function.

Have you looked through chrome uses of responseXML and made sure they can all handle null?  Or was toolkit/components/search/nsSearchService.js caught by tests?

Have you looked at addons mxr for consumers of this stuff at all?
Comment 59 Thomas Wisniewski 2016-07-28 12:30:25 PDT
Hmm, thanks for that feedback. I'll reconsider the patch accordingly.

>Have you looked through chrome uses of responseXML and made sure they can all handle null?  Or was toolkit/components/search/nsSearchService.js caught by tests?

I did look through the codebase for mentions of parsererror and its error-page URI, but that indeed may not have been enough (at least a try attempt didn't find anything, for what that's worth).

>Have you looked at addons mxr for consumers of this stuff at all?

No, I'm not sure how to do that. Was there documentation on using addons mxr?
Comment 60 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 12:48:54 PDT
I gues dxr now, not mxr.

You go to https://dxr.mozilla.org/addons/source/ (assuming you have the permissions to log in to that; let me know if you don't) and then you can search stuff.  I definitely see a ton of hits on "parsererror" in there....
Comment 61 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 12:50:39 PDT
But some of them might be using DOMParser, not XHR...
Comment 62 Thomas Wisniewski 2016-07-28 12:52:07 PDT
Ok, good to know. I don't have a Mozilla LDAP account yet, so I can't log into the site. Is there a specific process I should follow to get an LDAP account?
Comment 63 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 13:03:48 PDT
Hmm...  I actually don't know.  I expect you do have an LDAP account if you can push to try, though you may not know the username/password.  But not all LDAP accounts have access to addons source and I'm not sure what the procedure there is.

In any case, I'm seeing 140000-some hits on parsererror in addons.  And at least some are from XHR.

Maybe it's worth only changing non-system-principal XHR or something.  :(

Jorge, how do you think we should proceed here?
Comment 64 Thomas Wisniewski 2016-07-28 13:12:15 PDT
Hmm. Would it be possible to only do so for "older" addons, so that WebExtensions also have the standards-dictated behavior?

Edge 13 and 14 preview also return a null responseXML and keep the response as text. I'm also trying to build WebKit-gtk on my devbox to confirm what happens there.
Comment 65 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 13:29:59 PDT
If you have a pointer to a testcase, I can just try it in Safari for you.

For the rest.... I'm not sure whether we have a way to detect whether our caller is a webextension or not.  If we do, it makes sense to give them the new behavior, yes.
Comment 66 Thomas Wisniewski 2016-07-28 13:43:51 PDT
Sure, I have a test-case running at http://thomas.tanrei.ca/xhrtest.html

Unless Safari is different, it should show that responseXML=null and response="<xml>test/ml>"
Comment 67 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 13:50:26 PDT
Yep, that's what it's showing.
Comment 68 Thomas Wisniewski 2016-07-28 14:00:39 PDT
Alright, are there other browsers we ought to test, or is it sufficient for our purposes that Chrome, Edge, and Safari don't yield parsererrors?
Comment 69 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 14:12:20 PDT
That's sufficient for web compat, yes.  ;)
Comment 70 Jorge Villalobos [:jorgev] 2016-07-28 16:46:27 PDT
I gave the results a quick look and two things stand out:

1) jquery is flagged, so that generates tons of results. Assuming jquery handles this change gracefully, we can discard them.

2) BrandThunder add-ons are flagged, and there are hundreds of those. Adding Mike Kaply who might be able to tell us if they rely on this behavior and whether it's an easy change to adapt to.

I'm only starting to use DXR, so I don't know how to filter these out and see what else is left.

As for giving Thomas access, it would be good to know if he has an LDAP account first :)
Comment 71 Thomas Wisniewski 2016-07-28 16:58:48 PDT
If I do have one, I don't know the credentials. Is there someone I should ping to find out?
Comment 72 Boris Zbarsky [:bz] (still a bit busy) 2016-07-28 19:15:12 PDT
> assuming jquery handles this change gracefully, we can discard them.

Hmm.  The relevant jQuery code is:


	httpData: function( xhr, type, filter ) {
		var ct = xhr.getResponseHeader("content-type"),
			xml = type == "xml" || !type && ct && ct.indexOf("xml") >= 0,
			data = xml ? xhr.responseXML : xhr.responseText;

		if ( xml && data.documentElement.tagName == "parsererror" )
			throw "parsererror";

I guess in other browsers it ends up throwing something other than "parsererror" is all.

Needinfoing Mike for the brandthunder thing.
Comment 73 Mike Kaply [:mkaply] 2016-07-28 19:38:36 PDT
I assume you mean these lines:

chrome/content/bindings/btpfeedreader.xml:              if (this.responseXML.documentElement.nodeName == 'parsererror') {
chrome/content/bindings/btpfeedreader.xml:                if (dom.documentElement.nodeName == 'parsererror') {

In various add-ons. If the behavior breaks, it doesn't bother me. Those are rare error cases anyway (bt is sunsetting a lot of this stuff).

So they're good.


That being said, will there be any way to know it's a parser error versus something else?

parsererrors can be fixed (and that's exactly what I do - attempt to fix up responseText and reparse).

The only way I know that is because of the parsererror on the node...
Comment 74 Thomas Wisniewski 2016-07-28 21:02:12 PDT
>That being said, will there be any way to know it's a parser error versus something else?

I'm not 100% sure on that. Unfortunately, as per comments such as 34 and 36, it was deemed too web-incompatible to just fire an onerror with a more precise reason in this case. We could side-step the issue for addons/system code (as per comment 63) by allowing system/privileged XHRs to continue getting parsererror nodes (though I would prefer if WebExtensions wouldn't allow such a hack). Or perhaps the spec could be extended to add a "parserError" type of attribute on the XHR itself in that kind of event, but I admit that I'm doubtful that kind of idea would gain traction (I'm certainly up for trying, though).

So as it stands right now, per spec one would always get a "successful" XHR (onload/readystatechange=4) on parser errors, but with a null responseXML. I'd imagine there are other ways to end up in the same condition, but thankfully the DOMParser code still has to return parsererror nodes (also for web-compat reasons, funny enough). As such one could at least re-parse the responseText with DOMParser to get a more precise error case, even if that's sub-optimal.

PS: speaking of not allowing an IsSystemXHR() hack for WebExtensions, a quick glance at the codebase shows a isWebExtensionContentScript property which seems almost promising, but I'm not sure if that could be easily used by the XHR code.
Comment 75 Johnny Stenback (:jst, jst@mozilla.com) 2016-07-28 22:39:22 PDT
Nothing should be stopping us from firing a parseerror event or what not in Chrome if that'd be needed to be able to clearly distinguish between parse errors and other failures...
Comment 76 Thomas Wisniewski 2016-08-01 16:47:18 PDT
Created attachment 8776761 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

Alright, here's a version of the patch addressing your review comments, bz.

Ultimately I decided to just keep doing things the same way as they're being done now, for chrome XHRs (ie, keep sending a parsererror element). Web content and WebExtensions will get the spec-compliant behavior, and the biggest change to the patch consists of the checks to verify whether we're in a WebExt or not. I haven't added any test-cases for these bits yet, but I did at least confirm by hand that things work as I would expect, so I figure this is at least review-worthy.

Note that I also corrected the web platform test's issue that you mentioned in comment 57, so we'll now pass that test completely.

A fresh try run is ongoing: https://treeherder.mozilla.org/#/jobs?repo=try&revision=eaefaafd2bc5
Comment 77 Boris Zbarsky [:bz] (still a bit busy) 2016-08-02 09:26:24 PDT
Comment on attachment 8776761 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

The nsIDocument additions still need documentation.

>@@ -2057,16 +2070,18 @@ XMLHttpRequestMainThread::OnStopRequest(

Worth adding a comment here about how we have to snapshot the charset information before we possibly null out mResponseXML in XML parsing error cases.

>+++ b/dom/xhr/XMLHttpRequestMainThread.h

Would it make sense to add a JSContext argument to the RequestBody overload of Send() and pass one in from all the callsites, then have just one |mInWebExtension = InWebExtension(aCx)| thing?

Why are the failures in testing/web-platform/tests/XMLHttpRequest/responsexml-non-well-formed.htm back with this patch?

I'm not seeing a test for the "get responseText during load" thing....
Comment 78 Thomas Wisniewski 2016-08-02 09:33:29 PDT
Sure, I'll add some comments to nsIDocument and OnStopRequest.


>Would it make sense to add a JSContext argument to the RequestBody overload of Send() and pass one in from all the callsites, then have just one |mInWebExtension = InWebExtension(aCx)| thing?

Yes, I think so. Either way's fine by me, as long as the overall approach looks fine.


>Why are the failures in testing/web-platform/tests/XMLHttpRequest/responsexml-non-well-formed.htm back with this patch?

That's just because I forgot to include the change that marks the tests as passing now.


>I'm not seeing a test for the "get responseText during load" thing....

Right, I'll try to fashion one ASAP.
Comment 79 Boris Zbarsky [:bz] (still a bit busy) 2016-08-02 10:06:40 PDT
Bill, is "isWebExtensionContentScript" the right thing to test to detect web extensions code?  Or is there web extension code that is not running in those sandboxes but can do XHR?
Comment 80 Boris Zbarsky [:bz] (still a bit busy) 2016-08-02 12:59:24 PDT
This is definitely going to need an intent to ship, by the way...
Comment 81 Thomas Wisniewski 2016-08-02 14:35:41 PDT
Alright, I just sent one. Hopefully it'll appear on the list soon (I subscribed to the list days ago).
Comment 82 [PTO to Dec5] Bill McCloskey (:billm) 2016-08-02 14:53:51 PDT
(In reply to Boris Zbarsky [:bz] from comment #79)
> Bill, is "isWebExtensionContentScript" the right thing to test to detect web
> extensions code?  Or is there web extension code that is not running in
> those sandboxes but can do XHR?

No, it's not sufficient. Most web extension code (all of which can do XHRs) runs in the context of a normal web page, not a sandbox. Only content scripts run in a Sandbox.

WebExtension XHRs don't use system principals, in case that helps here.
Comment 83 Boris Zbarsky [:bz] (still a bit busy) 2016-08-02 14:58:21 PDT
> Most web extension code (all of which can do XHRs) runs in the context of a normal web page

That should be fine.  We want webextensions to match web pages, so we want to change the behavior of both.

So webextensions aren't running someplace where they get xrays?

I guess the real question is whether IsSystemXHR() would ever be true for a webextension.  I guess sounds like it wouldn't?
Comment 84 [PTO to Dec5] Bill McCloskey (:billm) 2016-08-02 15:07:43 PDT
(In reply to Boris Zbarsky [:bz] from comment #83)
> > Most web extension code (all of which can do XHRs) runs in the context of a normal web page
> 
> That should be fine.  We want webextensions to match web pages, so we want
> to change the behavior of both.
> 
> So webextensions aren't running someplace where they get xrays?

Content scripts do get Xrays. These are the ones that run in sandboxes (and where that flag is true).

> I guess the real question is whether IsSystemXHR() would ever be true for a
> webextension.  I guess sounds like it wouldn't?

It shouldn't ever be true. If it is, that's a bug.
Comment 85 Boris Zbarsky [:bz] (still a bit busy) 2016-08-02 15:13:41 PDT
Aha.  Sounds like we don't need to do the webextension check at all, then.
Comment 86 Boris Zbarsky [:bz] (still a bit busy) 2016-08-02 15:14:18 PDT
And ideally add tests for xhr in a webextension, both in and not in a content script.
Comment 87 Thomas Wisniewski 2016-08-02 15:37:08 PDT
Yeah, after giving it a test, it seems like both content and background scripts aren't considered SystemXHRs after all, so I'll just try to find out how to add test-cases for both cases, as well as the other test and any comments/documentation.
Comment 88 Thomas Wisniewski 2016-08-14 22:39:43 PDT
Created attachment 8780995 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

Alright, I think I've managed to figure out how to test the various things that needed testing, so here's a fresh version of the patch for review.

Try run here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e3edc7fb72bf

Since :bz's gone for a while, and the biggest change here is the web-extension tests, would you mind giving those parts a review, :billm? (I'm not sure who should take a look at them, nor how any reviews should be split at this point).

I'm also not sure how to "correctly" silence ESLint's complaints about "chrome" being undefined in the webextension files I added to the tree. Any suggestions besides just adding "eslint-disable-next-line no-undef" (or equivalent) comments?
Comment 89 [PTO to Dec5] Bill McCloskey (:billm) 2016-08-15 15:10:19 PDT
Comment on attachment 8780995 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

Review of attachment 8780995 [details] [diff] [review]:
-----------------------------------------------------------------

This probably works, but we have a much nicer way of testing WebExtensions. See here for an example:
http://searchfox.org/mozilla-central/source/toolkit/components/extensions/test/mochitest/test_ext_contentscript_context.html
(There are lots more in the same directory.)

This works better because:
- We don't have to check in XPIs.
- You can put the entire test in one file.
- You can use the browser.test API to communicate between the extension and the test harness.

Also, please use browser.foo instead of chrome.foo.

Sorry to make you re-do this, but I think it will be a lot nicer this way!
Comment 90 Thomas Wisniewski 2016-08-17 10:02:07 PDT
Created attachment 8782058 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

No problem, I wish I'd seen those tests before I wrote the previous version :)

Here's a new version of the patch that models the test after the nicer versions. Note that I had to split the system XHR part of the test out into another mochitest location, where XHRs are run as system XHRs.

---

Also, bz, I just realized that my test for the "match text charset to document's charset" corner case doesn't test what it's supposed to test, so I tried again. Unfortunately, I can't seem to find a way to actually hit that corner case.

For it to happen, the user would have to call GetResponseText before we've received enough of the document to sniff out its charset, since calling xhr.overrideMimeType is not allowed after the document starts loading.

We also don't parse HTML documents unless the responseType is "document", and reading the responseText isn't permitted in that case. (That means I can't just add in a <meta charset> which doesn't end up in the first chunk of data).

The only other way I can think to test this is to send just the first byte of a BOM, and then the rest after the user calls GetResponseText. But when I do this the XML always comes out as UTF-8, and I'm not sure if it's a bug in the XML parser or intentional behavior.

If it's intentional then how else are we supposed to hit this edge case? (Hopefully I'm missing something obvious?)
Comment 91 Thomas Wisniewski 2016-08-17 11:09:38 PDT
Hmm. XML encoding declarations seem to be completely ignored, so that's a no-go for the corner case as well.
Comment 92 [PTO to Dec5] Bill McCloskey (:billm) 2016-08-18 14:54:40 PDT
Comment on attachment 8782058 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

Review of attachment 8782058 [details] [diff] [review]:
-----------------------------------------------------------------

r+ for the webextension test.
Comment 93 Boris Zbarsky [:bz] (still a bit busy) 2016-08-22 14:48:18 PDT
Thomas, which corner case are you referring to in comment 90?  Do you mean the "No, this is wrong" bit from my review from comment 58?

If so, all you need to do is get responseText once the document charset is known but before OnStartRequest happens.  There should be no need for overrideMimeType in that situation: just an XML document with a "weird" charset (pretty much anything that's not "UTF-8", afaict) declared in the <?xml ...?> bit at the beginning.  Oh, and no charset stuff coming from HTTP headers (easy enough), and some non-ASCII bytes in that document so you can tell apart it being treated as UTF-8 and the specified charset.  Then you need to make sure we can get the responseText before OnStopRequest (e.g. get it off a progress event that we fire before OnStopRequest) and see whether the non-ASCII things are correct.

If you meant some other corner case, please let me know which one?
Comment 94 Thomas Wisniewski 2016-08-22 17:53:22 PDT
Created attachment 8783764 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

No, that was indeed the corner case I was referring to. Thanks for the insight, I was certainly over-thinking things.

Here's a new patch that should do the trick, assuming the setTimeout approach used is unlikely to cause intermittent failures. Note that :billm already reviewed the new web extensions test in this version (in case you missed those comments).
Comment 95 Boris Zbarsky [:bz] (still a bit busy) 2016-08-25 11:21:13 PDT
Comment on attachment 8783764 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

The 1s delay thing in bug289714.sjs seems racy... If we just lose the timeslice for 1s, I see nothing preventing the two pieces being coalesced into a single packet.

I recently saw some discussion going by about guaranteeing progress events, or at least multiple OnDataAvailable calls, by just ensuring the data is large enough (over 32KB?).  Can we do that here?

I guess the problem then would be ensuring that you know what to compare the text to, but you could do a substring match instead of equality match, right?

r=me with this addressed
Comment 96 Thomas Wisniewski 2016-08-29 19:36:50 PDT
Created attachment 8786168 [details] [diff] [review]
289714-null-responseXML-for-invalid-xml-xhrs-from-web-content.diff

Sure, here's a version that uses the same "32k" approach from bug 918719, and so should be less prone to races. Carrying over r+, as I didn't change anything except what you suggested.
Comment 97 Thomas Wisniewski 2016-08-29 19:38:22 PDT
Created attachment 8786169 [details] [diff] [review]
289714-make-console-xml-parsing-notices-more-informative.diff

And here's a fresh copy of the other patch.

Try still seems fine with both patches applied: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ec4b5bdf1f50

Carrying over r+ and requesting check-in of both patches.
Comment 98 Pulsebot 2016-08-29 20:44:03 PDT
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c9ccb7a95588
Do not write <parsererror> nodes for invalid XML documents in XMLHttpRequests made by web content. r=billm, r=bz
https://hg.mozilla.org/integration/mozilla-inbound/rev/3aeb398df5c6
Make console XML Parsing notices more informative. r=jst
Comment 100 Francesco Lodolo [:flod] 2016-08-30 07:06:38 PDT
Thomas, is there any technical limitation preventing from using a different string ID in the .properties file, to reflect the updated content?

If we want to make sure all localizations are updated, we'd need a new ID
https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Changing_existing_strings
Comment 101 Thomas Wisniewski 2016-08-30 07:34:24 PDT
Hmm, I'm not entirely sure what the best course of action is here. hallvors suggested this change in comment 38 to simply tweak that specific text, and I'm not sure if other localizations need to be similarly tweaked.

bz, what do you think is the best course of action here? Some obvious options:
- leave things as they are now (having changed the wording for just the default localization and hoping the others are fine)
- changing nsExpatDriver::HandleError to remap expat's internal error code 3 to a new l10n string id.
- just revert the wording-change and leaving the text as it was.
Comment 102 Boris Zbarsky [:bz] (still a bit busy) 2016-08-30 07:39:04 PDT
I don't have a strong opinion, really.
Comment 103 Thomas Wisniewski 2016-08-30 07:42:23 PDT
Fair enough. I'm veering toward just leaving things as they are, since other localizations won't be any worse than they were, even if their text could be updated (the change in the message isn't *that* substantial). Is that alright with you, flod?
Comment 104 Francesco Lodolo [:flod] 2016-08-30 07:43:24 PDT
OK. I'll make sure to send a note about this string when the Aurora cycle starts, at least we should get a few more locales up to date.
Comment 105 Thomas Wisniewski 2016-09-01 20:17:01 PDT
*** Bug 313854 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.